tabview groups should be represented in about:sessionrestore

RESOLVED WONTFIX

Status

()

Firefox
Session Restore
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: GPHemsley, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

7 years ago
Right now (in beta 4), the about:sessionrestore dialog does not make any indication about the existence of tab groups. As a result, it lists tabs in a single list, in a seemingly-random order.

Given that the list is already hierarchical with regard to windows, an additional layer of hierarchy should be added with regard to groups.

This also allows the added benefit of using the tab group names as their level indicators, in contrast to the generic "Window 1" indicators for windows.
a few notes:

- groups will no longer be window specific after bug 578512 lands, so if we do something like this, they'll have to be represented separately from windows somehow.

- groups don't always have a name (i've never named mine).
Component: TabCandy → Session Restore
QA Contact: tabcandy → session.restore
Summary: Improve integration with about:sessionrestore by adding another layer of hierarchy → tabview groups should be represented in about:sessionrestore
Depends on: 578512, 588217
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> a few notes:
> 
> - groups will no longer be window specific after bug 578512 lands, so if we do
> something like this, they'll have to be represented separately from windows
> somehow.
If that's the case, then the concept of windows need not even exist. (At least, not in Session Restore.)

> - groups don't always have a name (i've never named mine).
True, I'd forgotten about that. But if you don't name your groups, you're probably not using them to the full extent of their usefulness (IMO).
Duplicate of this bug: 598588
This is independent of all-windows Panorama view, but it seems like it should block. I keep seeing things like bug 598707 which to the unsuspecting eye seem like session store-related problems.
blocking2.0: --- → ?
(Reporter)

Updated

7 years ago
Depends on: 598843
Here's Aza's design for this feature (section 3 on the page):

https://wiki.mozilla.org/Firefox/Projects/TabCandy/Design/BrowserRestart

We have bug 599213 for the Tab Candy side of the implementation; close as duplicate if this should all happen in one bug.
Blocks: 599213
This does not block the release. Another level of categorization in the restore UI would be nice, but is not absolutely required for the purpose of narrowing down crashy tabs for selective restoration.

(In reply to comment #4)
> This is independent of all-windows Panorama view, but it seems like it should
> block. I keep seeing things like bug 598707 which to the unsuspecting eye seem
> like session store-related problems.

That is not related to this bug. This bug is about representing groups in the session restore UI.
blocking2.0: ? → -
We'll implement bug 588217 as part of Panorama displaying all tabs from all windows (so that window == group) and therefore won't need a new level of categorization in about:sessionrestore.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.