All users were logged out of Bugzilla on October 13th, 2018

Remove large size branch from GC::Alloc

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
22 hours ago

People

(Reporter: treilly, Unassigned)

Tracking

unspecified
Future
x86
Mac OS X
Bug Flags:
flashplayer-qrb +

Details

(Whiteboard: PACMAN)

(Reporter)

Description

8 years ago
If we made GCLargeAlloc a GCAlloc and placed it at the end of the GCAlloc's array and had a branch-free way to clamp the size class index to the end of the size class array we could remove a branch from GC::Alloc

I think this can be made to work:

http://bob.allegronetwork.com/prog/tricks.html#clamp
(Reporter)

Updated

8 years ago
Whiteboard: PACMAN

Updated

8 years ago
Target Milestone: --- → Future

Comment 1

8 years ago
This is probably not important because in almost all cases that test is or can be constant-folded (needs to be substantiated, but it is credible).

Updated

8 years ago
Duplicate of this bug: 557898

Updated

7 years ago
Flags: flashplayer-qrb+
Status: NEW → RESOLVED
Last Resolved: 22 hours ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.