Firefox hangs/crashes during file transfer/rendering of PDF files

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Jerry.Linn59, Unassigned)

Tracking

x86
Windows XP

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

I have repeated experienced Firefox crashing/hanging during download of PDF files that Opera V9 and IE V7 can download quickly and without any problems.  Today I upgraded from Firefox/3.6.4 to 3.6.8 and the problem persists.  The link below exemplifies the problem -- 2 level "sale catalog" from Bob Drake auto parts: the link below is for level 1, and several of the level 2 components could not be opened, rendered and saved.
                http://www.bobdrake.com/SALE/BTS-Sale-10.html
Hope this is sufficient information for someone to make sense of it and fix it.

Reproducible: Sometimes

Steps to Reproduce:
1.Open the link in the details above, and click on the buttons for the components (level 2) pdf files.
2.
3.
Actual Results:  
Firefox hangs and does not respond.  Have to kill the application with Windows Task manager.

Expected Results:  
Have to restart Firefox.  Most likely will not complete the file transfer and render the whole document.

Should allow the user to kill the file transfer and regain control; the kill button for file transfer is dead; (all buttons) are dead -- Firefox does not respond to ANY cursor input, and you cannot close the process from the normal right click on the icon associated with the task -- Windows reports that the process "is not responding".
(Reporter)

Comment 1

8 years ago
Created attachment 470428 [details]
Report generated by Firefox after clicking Help/Troubleshooting
(Reporter)

Comment 2

8 years ago
Created attachment 470429 [details]
A copy of the screen image with the Error Console Reports

Report generated by Firefox Click: Tools/Error console (CTRL+SHIFT+J)
You forgot one important part. 
Do you use a plugin for viewing PDFs and which one (Name and version) and is that the latest version of this plugin ?

Do you tried http://support.mozilla.com/en-US/kb/Safe+Mode ?
(Reporter)

Comment 4

8 years ago
Created attachment 470480 [details]
Copy of the list of plugins and support for PDF in Firefox


--- Comment #3 from Matthias "matti" Versen <matti@mversen.de> 2010-08-30 08:26:35 PDT ---
  >You forgot one important part.
  >Do you use a plugin for viewing PDFs and which one (Name and version) and is
  >that the latest version of this plugin ?
SEE Attachment that was added -- I don't know if this is the latest plugin. I believe Firefox checks the compatibility of plugs when updated software is installed, and will fetch it -- at least that is my experience with other plugins.  If this is not correct, I don't know how to install or update plugins.

   >Do you tried http://support.mozilla.com/en-US/kb/Safe+Mode ?

No, I have not tried safe mode (don't know how to do that).  

I have tried to give you a "reasonable" amount of information, but am only an OLD technical guy and retired manager of guys and gals that wrote code.  So, I don't expect to trouble shoot this myself.
Can you please try to upgrade your Acrobat Reader ?
- http://get.adobe.com/de/reader/
You have 9.3.0.148 installed according to your screenshot.


>So, I don't expect to trouble shoot this myself.

I can't reproduce your problem on my system. The safemode disables all addons temporary and it should be easy to follow the steps in the safemode link.
In many cases installed addons are causing freezes.

A workaround should be to set tools/options/applications/Acrobat.. to the not "(inline)" option.

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 6

8 years ago
Hi,
Thanks for the suggestion to update Adobe Reader;  this evening I was able to fetch and render all parts of the document without hanging.  (The reason I had not updated Adobe Reader is there was a bug that lasted over several updates -- Reader would not print after being updated.)

Thanks
Jerry
So this works fine now? INVALID then, as it was a bug in acrobat.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

8 years ago
Tyler,
I don't know how you determine that it is a bug in Acrobat ...
Is Firefox responsible for the file transfer (HTTP), and if so, and Firefox stalls during the file transfer, it appears to me that the underlying issue is in Firefox, not Acrobat reader.  Recall, when I reported this problem, both OPERA and IE were able to open, render and transfer the entire files without stalling, using the old version of Reader.  Also, recall that Firefox had to be KILLED using Windows task manager because it was hung up and "unresponsive."  So, obviously, there is an issue -- or I would not have wasted my time submitting an "invalid" report.
Jerry
Resolution: INVALID → FIXED
You said in comment 6 that after updating reader you were able to load the document without a hang, correct?
Resolution: FIXED → INVALID

Comment 10

8 years ago
Our instructions are designed for end users.

http://support.mozilla.com/en-US/kb/Safe+Mode is easy to read and easy to follow. As it happens, it wouldn't have helped in this case, but we do appreciate it if people actually read and follow the instructions they're given instead of ignoring them. We work hard to write these instructions, please do show some appreciation by actually reading them.

Plugins and Firefox share a process, there is no way for you as an end user to know which of the two is at fault, and in fact it's pretty much impossible for someone like Matti or Tyler to be able to determine from your description which is truly at fault. All they can do is make an educated guess.

If your problem goes away when you update Acrobat Reader, then it's perfectly reasonable to assume that the version of Acrobat Reader you were using was buggy.

Tyler/Matti: please move plugin bugs to the plugins product (and the appropriate component). For bugs which WFM from the perspective of "updating a plugin results in the problem going away", then please use WFM (it makes reporters happy too). This only applies to the Plugins product of course.

Matti: please favor <http://get.adobe.com/reader/> over links w/ /de/ in them when speaking in English ;-)

Jerry: your data indicated you were using 9.3.0, the current version of Adobe Reader is 9.3.4, if upon upgrading your problem went away, we're happy to blame Adobe (and they're happy to take the blame since they've probably Fixed the problem on their end).

If you can reproduce the problem in the future, you can indicate as such and someone will provide you with a url which contains instructions which you would have to follow in order for an engineer to get useful information to determine what's actually going wrong. Yes, this requires you to read and follow directions. If you aren't willing to do that, we can't really help.

And by we, I really mean *me*.
Component: General → PDF (Adobe)
Product: Firefox → Plugins
QA Contact: general → adobe-reader
Resolution: INVALID → WORKSFORME
Version: 3.6 Branch → 9.x
>Matti: please favor <http://get.adobe.com/reader/> over links w/ /de/ in them
>when speaking in English ;-)

The stupid websites are always redirecting me based on my IP and I usually remove the de part but it seems to forgot it this time.

>Tyler/Matti: please move plugin bugs to the plugins product (and the
>appropriate component).

I move bugs to Plugins/* if I think that the bug is in the plugin and not Gecko. This would be the case for this report but I don't think it matters if the bug is already fixed in recent versions.
(Assignee)

Updated

3 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.