Last Comment Bug 591933 - TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | This script was supposed to get fetched.
: TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug53429...
Status: RESOLVED WORKSFORME
: intermittent-failure
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2010-08-30 08:22 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jeff Muizelaar [:jrmuizel] 2010-08-30 08:22:02 PDT
26 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | Slow script ran.
27 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | This script is supposed to run.
28 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | This script was not supposed to get fetched.
29 ERROR TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | This script was supposed to get fetched.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1283171487.1283172249.23153.gz#err0

It looks like we might be having is race with the loads.
Comment 1 Henri Sivonen (:hsivonen) 2010-09-08 06:29:18 PDT
The slow script tries to be slow for half a second. Apparently it's not long enough here. But then there's the other side of the coin: bug 590874.
Comment 2 Ed Morley [:emorley] 2012-09-29 07:55:51 PDT
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500

Note You need to log in before you can comment on or make changes to this bug.