AwesomeBar shows a different subdomain in search results when another subdomain is a substring

RESOLVED DUPLICATE of bug 506863

Status

()

RESOLVED DUPLICATE of bug 506863
8 years ago
8 years ago

People

(Reporter: paulc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
This is probably a rare situation. The screenshot explains it all. [1]

STR:
1. Have two subdomains, one containing the other as a substring, e.g.
(1) support-stage.mozilla.com
(2) mobile-support-stage.mozilla.com
2. When visiting (1), I wanted to go to a different page on the same subdomain, and edited the last part of the URL.

Actual results:
The first result is on a different subdomain.

Expected:
A different subdomain shouldn't match? At least not if I have the http(s):// prefix in the URL as well. I'm not quite sure, but the current behavior surprised me.


[1] http://img245.imageshack.us/img245/7097/screenshot20100830at122.png
we strip prefixing http, https, ftp from the searched term to give more global results
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506863
(Reporter)

Comment 2

8 years ago
Yeah. Tough call. The way I think of it: if it's explicitly provided, don't strip it. Now how to define "explicitly provided", I don't know. Perhaps as "typed" or "pasted" as opposed to "found through the dropdown results" but I guess there's lots of edge cases to consider :(
You need to log in before you can comment on or make changes to this bug.