Crash in [@ strlen | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ] or [@ memcpy | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ]

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
--
critical
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100828
Firefox/4.0b5pre

This is two new crash signatures which have been introduced by this build.
For the last week, it is now the #5 (strlen) and #8 (mecopy) crasher for b5pre.

Signature	strlen | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int)
UUID	d347e2f3-378a-45c1-86b0-7bf922100830
Time 	2010-08-30 09:53:18.798056
Uptime	409
Last Crash	84800 seconds (23.6 hours) before submission
Install Age	409 seconds (6.8 minutes) since version was first installed.
Product	Firefox
Version	4.0b5pre
Build ID	20100830040705
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x7c297463
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozcrt19.dll 	strlen 	strlen.asm:69
1 	xul.dll 	nsACString_internal::Replace 	xpcom/string/src/nsTSubstring.cpp:477
2 	mozcrt19.dll 	realloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6067
3 	xul.dll 	nsHttpRequestHead::Flatten 	netwerk/protocol/http/nsHttpRequestHead.cpp:68
4 	xul.dll 	nsHttpTransaction::Init 	netwerk/protocol/http/nsHttpTransaction.cpp:251
5 	xul.dll 	nsHttpChannel::SetupTransaction 	netwerk/protocol/http/nsHttpChannel.cpp:658
6 	xul.dll 	nsHttpChannel::Connect 	netwerk/protocol/http/nsHttpChannel.cpp:316
7 	xul.dll 	nsHttpChannel::OnNormalCacheEntryAvailable 	netwerk/protocol/http/nsHttpChannel.cpp:2236
8 	xul.dll 	nsHttpChannel::OnCacheEntryAvailable 	netwerk/protocol/http/nsHttpChannel.cpp:4450
9 	xul.dll 	nsCacheListenerEvent::Run 	netwerk/cache/nsCacheService.cpp:1159
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
11 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
12 	xul.dll 	xul.dll@0xb99e53 	
13 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
14 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
15 	xul.dll 	nsSupportsStringImpl::QueryInterface 	xpcom/ds/nsSupportsPrimitives.cpp:148
16 	xul.dll 	_SEH_epilog4 	
17 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
18 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:175
19 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:243

Signature	memcpy | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int)
UUID	e32f9017-3eef-4dd3-8771-ff6322100828
Time 	2010-08-28 09:40:42.509145
Uptime	119
Last Crash	1752 seconds (29.2 minutes) before submission
Install Age	2238 seconds (37.3 minutes) since version was first installed.
Product	Firefox
Version	4.0b5pre
Build ID	20100828040640
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 15 model 4 stepping 9
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0xffffffff88ee0e98
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozcrt19.dll 	memcpy 	memcpy.asm:233
1 	xul.dll 	nsACString_internal::Replace 	xpcom/string/src/nsTSubstring.cpp:490
2 	mozcrt19.dll 	realloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6067
3 	xul.dll 	nsHttpRequestHead::Flatten 	netwerk/protocol/http/nsHttpRequestHead.cpp:68
4 	xul.dll 	nsHttpTransaction::Init 	netwerk/protocol/http/nsHttpTransaction.cpp:251
5 	xul.dll 	nsHttpChannel::SetupTransaction 	netwerk/protocol/http/nsHttpChannel.cpp:658
6 	xul.dll 	nsHttpChannel::Connect 	netwerk/protocol/http/nsHttpChannel.cpp:316
7 	xul.dll 	nsHttpChannel::OnNormalCacheEntryAvailable 	netwerk/protocol/http/nsHttpChannel.cpp:2236
8 	xul.dll 	nsHttpChannel::OnCacheEntryAvailable 	netwerk/protocol/http/nsHttpChannel.cpp:4450
9 	xul.dll 	nsCacheListenerEvent::Run 	netwerk/cache/nsCacheService.cpp:1159
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
11 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
12 	xul.dll 	xul.dll@0xb96deb 	
13 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
14 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
15 	xul.dll 	_SEH_epilog4 	
16 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
17 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:175
18 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:243
19 		@0x777dffff 	
20 		@0x75c9ffff 	
21 	xul.dll 	nsTHashtable<nsPtrHashKey<nsIFrame> >::s_EnumStub 	obj-firefox/dist/include/nsTHashtable.h:420
22 		@0x76f8ffff

The regression window is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1d55bbd1d1d&tochange=6e3f6d18c124
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Keywords: crash
(Reporter)

Updated

8 years ago
Keywords: regressionwindow-wanted → regression
Can we get a narrower regression window here, please?
Keywords: qawanted, regressionwindow-wanted
(Reporter)

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100831
Firefox/4.0b5pre
The crash is gone.

I assume that the fix of bug 591657 fixes also this bug.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
blocking2.0: ? → ---
(Assignee)

Updated

7 years ago
Crash Signature: [@ strlen | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ] [@ memcpy | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ]
Issue is resolved - clearing old keywords - qa-wanted clean-up
Crash Signature: [@ strlen | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ] [@ memcpy | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ] → [@ strlen | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ] [@ memcpy | nsACString_internal::Replace(unsigned int, unsigned int, char const*, unsigned int) ]
Keywords: qawanted, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.