Closed Bug 592110 Opened 12 years ago Closed 12 years ago

XPConnect Errors: scope has no 'Components' property

Categories

(DevTools :: General, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: ddahl, Assigned: ddahl)

References

Details

(Whiteboard: [kd4b6])

###!!! ASSERTION: XPConnect is being called on a scope without a 'Components' property!: 'Error', file /home/ddahl/code/moz/mozilla-central/mozilla-central/js/src/xpconnect/src/xpcwrappednativescope.cpp, line 792

I get this error when trying to use the new lazy nsIDOMGlobalPropertyInitializer console object. This is the case when I dynamically create a script node via the console like: 
document.createElement("script").innerText = "function foo(){window.console.log('foo');}"

The patches required to reproduce this are on bug 568629 and bug 587734 as well as bug 589329 for some XPConnect patching

I may have some things wrapped incorrectly, not sure.
Blocks: 529086
Yeah, look like I am doing something weird here. /me keeps hacking.
Whiteboard: [kd4b6]
Severity: normal → blocker
Reprioritizing bugs. You can filter the mail on the word TEABAGS.
Severity: blocker → normal
Blocks: devtools4b7
I need to test this again, and is dependent on patches in bug 568629, so this can move to b7. (once the lazy console is properly wrapped, this bug may go away)
Blocks: devtools4b8
No longer blocks: devtools4b7
Assignee: nobody → ddahl
I think this was jumping the gun. I spoke with jst and he said this error is a common false positive. I have also since gottent hings working reasonably well. Leaving it open for a few more days, but will probably close it as invalid.
My tests were improperly unsetting eventListeners, etc... nothing to see here.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.