No prompt to save multiple tabs when closing window with menu bar hidden

RESOLVED FIXED in Firefox 4.0b7

Status

()

defect
--
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: myron02, Assigned: dao)

Tracking

({dataloss, regression})

Trunk
Firefox 4.0b7
x86_64
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100830 Firefox/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100830 Firefox/4.0b5pre

If there are multiple tabs and the menu bar is hidden, exiting the browser using the close button does not trigger a prompt to save the tabs.

Reproducible: Always

Steps to Reproduce:
1. Have at least 2 tabs open
2. Hide the menu bar (app menu is shown)
3. Close the window using the upper right close button (exiting through the app menu will trigger a prompt)
Actual Results:  
Window closes without prompt to save tabs.

Expected Results:  
There should be a prompt to save tabs.
Version: unspecified → Trunk
According to the latest nightly thread over on MozillaZine, this only affects XP, not Vista/7.
Blocks: 575870
No longer blocks: 575870
This problem is introduced by Bug 575870.
BrowserTryToCloseWindow should use instead of window.close.

browser/base/content/browser.xul
   <hbox id="titlebar-buttonbox">
     <toolbarbutton id="titlebar-min" oncommand="window.minimize();"/>
     <toolbarbutton id="titlebar-max" oncommand="onTitlebarMaxClick();"/>
-     <toolbarbutton id="titlebar-close" oncommand="window.close();"/>
+     <toolbarbutton id="titlebar-close" oncommand="BrowserTryToCloseWindow();"/>
   </hbox>
Blocks: 575870
Component: Session Restore → General
QA Contact: session.restore → general
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking2.0: --- → ?
Assignee: nobody → dao
Posted patch patchSplinter Review
Attachment #470794 - Flags: review?(gavin.sharp)
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: dataloss
blocking2.0: ? → betaN+
Attachment #470794 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/6b74e4f30457
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
Duplicate of this bug: 594022
Duplicate of this bug: 591356
Duplicate of this bug: 596579
This problem has not been fixed - it still occurs in Firefox 4.0 RC
Try about:config -> browser.showQuitWarning = true
What does "about:config" mean? Is that supposed to be some menu option somewhere, because I cannot see it anywhere in the UI. Can you provide a screenshot?
Type it into the location bar.
So I type "about:config" into the "URL field" and I get

This might void your warranty!
Changing these advanced settings can be harmful to the stability, security and performance of this application. You should only continue if you are sure of what you are doing.

OK - that is not a valid user experience.

So, it fixes the problem - cool!

So, prior to FF 4.0b10 I did not have this problem. After an automatic update to beta 10 the problem started. Until now I did not know how to fix the problem.

Issues:

1) There is still a bug! I don't care how you want to record it, but there is a serious defect here we are talking about.

2) The solution provided is not available through the Firefox UI, except as as trapdoor. No person could reasonably figure this out other than filing a bug report. Basically I'm saying the solution is "tribal knowledge."

Seriously, if Firefox wants to compete with Google Chrome in the long run, you just have to have way more respect for tabs.
Is there a reason about:config -> browser.showQuitWarning is set to false by default? I feel that it would be better to have the default as true and let people disable it if they want to.
I assume you are talking to others and not me. My assumption is that this was set or defaulted to true prior to beta 10, and then reset to false after beta 10, because that is when I stated having problems. Perhaps the setting added for beta 10 and whoever implemented forgot to initialize it to something reasonable.

I cannot imagine any same person who would want this default to false as it makes it impossible to save tabs between sessions, and it makes tab groups pretty much useless. But if you want to give people the choice, please set the default to true, and put a setting in the UI where people can find it and understand precisely what it means, instead of the current trapdoor.
Well, I just installed FF4 on a new Windows 7 system, and I had the same problem again:

about:config -> browser.showQuitWarning = false

and I had to set it to true. If no-one is going to fix this problem should I create a new bug report?
This has nothing to do with this bug. The preference was switched intentionally. See: http://blog.zpao.com/post/3174360617/about-that-quit-dialog
You need to log in before you can comment on or make changes to this bug.