If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mv-moz2-linux-ix-slave19 takes down dozens of nightlies, out of pty devices

RESOLVED FIXED

Status

Release Engineering
General
--
blocker
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Pike, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
mv-moz2-linux-ix-slave19 is dying on "out of pty devices", and takes down all l10n nightlies it can get to, on various builders, too.
(Assignee)

Comment 1

7 years ago
Yeah, I just ran into this on Mobile on the same machine.
It's been up for >23 hours so it's not rebooting properly.
It's normal for l10n not to reboot after a job, but mobile should I expect.
(Assignee)

Comment 3

7 years ago
Yeah, it should have rebooted this morning.
I tried running count_and_reboot manually by copy/pasting the buildbot step's command line, and that worked fine.

Still digging.
(Assignee)

Updated

7 years ago
Assignee: nobody → aki
(Assignee)

Comment 4

7 years ago
Cleaned up a massive /builds/slave/old directory (as well as the rest of /builds/slave), tested some reboots, and am currently trying to respin a build (already past the out of pty error)

Notable: it was fine until a reboot at 14:49 yesterday (Aug 30).
The next build died with the out of pty's at 23:30, and then it grabbed the slew of l10n repacks between 1 and 3am PDT.
(Assignee)

Comment 5

7 years ago
This seems better; mv-moz2-linux-ix-slave19 is back in the pool and green after a reboot.

I'm not sure this was a one time thing or if we'll see it again.
Seems like it's rare, at least.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.