ftp directory listing block X server under Linux

RESOLVED FIXED in mozilla1.0

Status

()

P3
major
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: augustmiles, Assigned: bryner)

Tracking

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When I open the above address by starting at the top of the

ftp.mozilla.org tree and opening the directories there is a dreadful
performance problem when opening the nightly directory.
It takes 15 second to list the directory. During this time
the mouse will hardly move on the screen. Mozilla seems really to
hammer the X server at this moment.
Gecko/20001105 build, downloaded from ftp.mozilla.org

Comment 1

19 years ago
updating component and setting default owner.
Assignee: asa → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: doronr → jrgm

Comment 2

18 years ago
->bryner to figure out whether this is more excessive round trips to the X
server, or perhaps rdf or ftp delays.  p3/moz0.9
Assignee: trudelle → bryner
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → mozilla0.8
(Assignee)

Comment 3

18 years ago
I'm not seeing any severe performance problems doing an ftp listing on a current
build.  Can you try to reproduce on a more recent nightly?  Also, what CPU speed
and RAM do you have?
(Reporter)

Comment 4

18 years ago
I ran on Gecko/20010111, Linux
Running under Suse/x86

I tried two machines:
stubbs: Bi-processor pentium II, 450Mhz, 256M ram, Matrix G400, Xfree3.3.6
holbein: Monoprocessor Pentium III, 800 Mhz, 256 ram, NVidia GeForce, Xfree4.

Both machines have performance problems with ftp listings (I am using
modern skin)

To factor out the network speed I tried listing a local mirror of redhat7 rpms.

Stubbs:
It takes about 20 seconds to list all the files, the X pointer
is very slow to react during this time as per report.

Holbein:
The X pointer remains fluid. However the directory listing takes
50 seconds.

As a reference netscape 4.7 finishes in about 3 seconds.

Comment 5

18 years ago
->moz0.9
Target Milestone: mozilla0.8 → mozilla0.9
So I tried this in a build and I didn't have any problems with it.  Looked fine
here.
(Assignee)

Comment 7

18 years ago
I don't think we're going to get anywhere on this bug specifically; dougt's ftp
changes and changing the directory viewer to use <outliner> will probably help
ftp performance though.

Setting moz1.0, unless someone wants to mark this FIXED.
Target Milestone: mozilla0.9 → mozilla1.0
(Assignee)

Comment 8

18 years ago
Is this still happening?
I haven't seen anything like this in a long long time.  ftp is working pretty
well these days.
(Reporter)

Comment 10

18 years ago
Well the default FTP display has been changed 
since the report. FTP just gives a plain view of
files, rather than a tree view, which was killing
all performance

I am marking as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.