Remove question mark from "Undo?" link

VERIFIED FIXED in mozilla2.0b7

Status

()

defect
--
trivial
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: dean_tessman, Assigned: tdowner)

Tracking

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Whiteboard: [good first bug][strings])

Attachments

(2 attachments, 2 obsolete attachments)

Posted image Screenshot
There's no reason to have a question mark at the end of "Undo?".  Following this logic, the other labels should be "Restart now?" and "More?".
Shorlander, need a call here. Boriss' mockups show a question mark on the "Restart Now" and "Undo" links randomly. Which should have question marks if any?
Keywords: uiwanted
The "following this logic" part of my comment was me being facetious.  Links and buttons don't have question marks at the end.
blocking2.0: --- → ?
Resolution blocks string freeze
blocking2.0: ? → beta6+
Whiteboard: [good first bug]
Posted patch Patch v1 (obsolete) — Splinter Review
Sound good?
Assignee: nobody → tyler.downer
Status: NEW → ASSIGNED
Attachment #471097 - Flags: ui-review?(shorlander)
Attachment #471097 - Flags: review?(dtownsend)
Comment on attachment 471097 [details] [diff] [review]
Patch v1

You're going to need to change the entity names, I suspect, to ensure that l10n carries over the translation. I suggest addon.undoAction.label and addon.undoRemove.label, but I also do wonder why we have two different labels here :)
Attachment #471097 - Flags: ui-review?(shorlander) → ui-review+
Posted patch Patch v2 (obsolete) — Splinter Review
I believe there are two labels because  the tooltip for undoUninstall (now undoRemove), is different than the one for undo (undoAction now). I also changed the tooltip's entity names to ensure consistency because we do have two different undos
Attachment #471097 - Attachment is obsolete: true
Attachment #471107 - Flags: review?(dtownsend)
Attachment #471097 - Flags: review?(dtownsend)
there we go. Spacing fix
Attachment #471107 - Attachment is obsolete: true
Attachment #471108 - Flags: review?(dtownsend)
Attachment #471107 - Flags: review?(dtownsend)
Whiteboard: [good first bug] → [good first bug][strings]
Attachment #471108 - Flags: review?(dtownsend) → review+
Beltzner gave UI+ on patch 1, carrying that forward.
Keywords: checkin-needed
Attachment #471108 - Flags: ui-review+
Attachment #471108 - Flags: approval2.0?
Keywords: checkin-needed
Comment on attachment 471108 [details] [diff] [review]
Fix whitespacing, v2.1

No approval needed for blockers, I'm about to land this
Attachment #471108 - Flags: approval2.0?
landed: http://hg.mozilla.org/mozilla-central/rev/b0334ccc6ee1
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
Depends on: 592947
Looks good in 20100902.
Status: RESOLVED → VERIFIED
No longer depends on: 592947
You need to log in before you can comment on or make changes to this bug.