Fake pages (via url manip) causing 500 on prod

VERIFIED FIXED in 5.12.6

Status

addons.mozilla.org Graveyard
Public Pages
P2
critical
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: tgavankar, Assigned: clouserw)

Tracking

unspecified
5.12.6

Details

(Reporter)

Description

8 years ago
If you go to a url that does not exist, such as http://addons.mozilla.org/en-US/firefox/fakepage, the page returned is blank, but it is returning a 500 error.

This does not occur for addon pages that are 404s, such as https://addons.mozilla.org/en-US/firefox/addon/6937125/ which are handled correctly.
HTTP/1.0 500 Internal Server Error
Server: Apache
X-Backend-Server: pm-app-amo11
Content-Type: text/html; charset=UTF-8
X-Amo-Darklaunch: z
Date: Tue, 31 Aug 2010 18:40:30 GMT
X-Amo-Servedby: pm-app-amo11
Via: Moz-Cache-zlb02
Connection: close
Set-Cookie: X-Mapping-kgbglcod=CCB9EAE0E687FE6259762461D6E3115A; path=/
X-Powered-By: PHP/5.2.9
X-Cache-Info: not cacheable; response code not cacheable
Content-Length: 0
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 623443
Why is this WONTFIX?
Severity: normal → critical
OS: Windows 7 → All
Priority: -- → P2
Hardware: x86 → All
Target Milestone: --- → 5.12.6
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 4

8 years ago
The link in comment 0 is a 404 for me.
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
All of these continue to have the problem:

https://addons.mozilla.org/en-US/firefox/fligtar
https://addons.mozilla.org/en-US/firefox/hello
https://addons.mozilla.org/wtf
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
also, I really don't like our current policy of immediately WONTFIXing/WORKSFORME when respected contributors clearly have problems. Please ask questions first and shoot later.
(Assignee)

Comment 7

8 years ago
I wasn't aware of that policy.  It turns out these only have errors if you're logged out.  Please provide more information about your environment if a respected contributor can't reproduce your problem.

This doesn't block dev tools, we can grab it in .7.
Target Milestone: 5.12.6 → 5.12.7
99% of our users are logged out and we serve 225,000 404 responses a day. This is a serious issue that needs immediate attention. This isn't related to dev tools but it needs to go out in the next release, which happens to be dev tools.

I really hope this same issue hasn't been around since August and am surprised automated tests haven't been nagging about this.
Status: REOPENED → NEW
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> 99% of our users are logged out and we serve 225,000 404 responses a day. This
> is a serious issue that needs immediate attention. This isn't related to dev
> tools but it needs to go out in the next release, which happens to be dev
> tools.
> 
> I really hope this same issue hasn't been around since August and am surprised
> automated tests haven't been nagging about this.

It's a weird error with our setup and I'll probably need oremj who is out until next weds I think.  We'll try to fit it in.
(Assignee)

Comment 10

8 years ago
I looked at this today so we could get it into this milestone.  It's the old simple_auth thing.  I changed our default user to nobody@mozilla.org which shows the 404 page instead of the "can't find user" 500 error.
Assignee: nobody → clouserw
Target Milestone: 5.12.7 → 5.12.6
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
thank you
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.