If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

printing causes a "print preview" to flash in the browser window while page is printing

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: dbaron, Assigned: tnikkel)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

When I print (just File -> Print, not from print preview), a display that looks a bit like the print preview display although I think without the edges (although I'm not sure if that's what it is) flashes in the browser window as the progress meter ticks up.  Then when printing is done, the normal page display flashes back into place.

Steps to reproduce:
 1. load http://hacks.mozilla.org/2010/08/fun-with-fast-javascript/
 2. choose File -> Print
 3. select print to file (to avoid wasting paper), and print it

Actual results: a printed display flashes in part of the browser window while the progressmeter for the printing is displayed

Expected results: page display doesn't change while the print progress is being shown

I'm testing in 2010-08-30-03-mozilla-central Linux x86_64 nightly.

Probably a regression from bug 130078 or related.
blocking2.0: --- → final+
(Assignee)

Comment 1

7 years ago
The same thing happens when you print from print preview.

The printed output looks fine. I think we must be doing an extra call to one of the functions in DocumentViewer that turns on printing mode for the wrong document.
Blocks: 592891
(Assignee)

Comment 2

7 years ago
Created attachment 472191 [details] [diff] [review]
patch

We link in the view manager for the print document into the screen view manager, so it gets drawn for a brief period.
Assignee: nobody → tnikkel
Attachment #472191 - Flags: review?(roc)
(Assignee)

Updated

7 years ago
Blocks: 585697
Attachment #472191 - Flags: review?(roc) → review+
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/mozilla-central/rev/08aab2f52228
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
No longer blocks: 585697
Duplicate of this bug: 592891
You need to log in before you can comment on or make changes to this bug.