xulPanel is null error when show/hide methods are called

RESOLVED WORKSFORME

Status

Add-on SDK
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: dbuc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When I show and hide a panel instance many times in a short period the panel eventually stops displaying content and creates empty duplicate panels without developer invocation.

Error: xulPanel is null
Source File: resource://jid0-xghcaywo8zlru6dgbj6voi2yy7m-jetpack-core-lib/securable-module.js -> resource://jid0-xghcaywo8zlru6dgbj6voi2yy7m-jetpack-core-lib/panel.js
Line: 343
(Reporter)

Comment 1

8 years ago
In restructuring the MailPing example for the upcoming blog post to work around this issue, I took an onClick approach to the showing of the panel and was able to replicate the error.

There is less of a chance of it occurring with click to hide/show (you have to click twice in a quick period) but it is does bork all panel functionality of any particular add-on for the entire session if it occurs. For this reason I believe this is a P1 bug, thoughts?
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Daniel: can you still reproduce this problem?
Whiteboard: [triage:followup]
(Reporter)

Comment 4

7 years ago
I will try to replicate it again, it has been a while since I last tested that flow, so perhaps it has been fixed. Will let you know what I find.
I can't reproduce the problem, so resolving worksforme, but please reopen if you can!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [triage:followup]
You need to log in before you can comment on or make changes to this bug.