No user message after successful registration/verification

VERIFIED FIXED in 5.11.9

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: clouserw)

Tracking

({regression})

5.11.9
regression

Details

(Whiteboard: [z], URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1.Load https://next.addons.mozilla.org/en-US/firefox/users/register
2.Create a new account

expected behavior:
After successful account creation,there is a success message informing the user to verify their email account.

actual behavior:
Login page loads without any success message

The user message is seen only when the user navigates back to the register page.
(Reporter)

Comment 1

8 years ago
Same case with email verification. There is no success message. On navigating to the registration page,the user can see the success page.
Summary: No user message after successful registration → No user message after successful registration/verification
(Reporter)

Comment 2

8 years ago
Same case with email verification. There is no success message. On navigating to the registration page,the user can see the success page.
Priority: -- → P2
Priority: P2 → P1
(Assignee)

Comment 3

8 years ago
The messages are being passed around and displayed as expected.  They don't show up correctly here because the log in page is still being displayed by remora.
(Assignee)

Comment 4

8 years ago
http://github.com/jbalogh/zamboni/commit/137ca0114f9571caed13118dacd59a5f02b4d2bf

and

r73695

The messages aren't gorgeous, but they are consistent with the other messages on that page in remora.  When remora is gone, they'll look like the other notification messages in zamboni.
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
The success message after account registration is-"Congratulations! Your user account was successfully created."

We do not tell the user that they need to confirm their email-id before logging in.

Fligtar says that the success message should include a message like-

An email has been sent to your address <email-id> to confirm your account. Before you can log in, you have to activate your account by clicking on the link provided in this email.

Thanks for registering and welcome to Firefox Add-ons!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks for registering! Before you log in, please check your email (email@domain.com) to confirm your account.

(I really wish we had multi-line success messages here!)
(Assignee)

Comment 7

8 years ago
I made the message simple because we can't pass the email address to remora.  The email address will be in the zamboni messages, but what message do you want, without vars, in the mean time?
What variable? email@domain.com is what we should use for every message.
JK LOL!@!@! Use the same message without the email.
(Assignee)

Comment 10

8 years ago
r73720
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

8 years ago
verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.