If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

I use "appendChild" to append a div containing an iframe to body, if there is another iframe in the page, the div's iframe will be filled with another iframe's content.

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: wu rui, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WFM?])

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

like the code below:
<body>

<div>   
	<div id="div1">
		<iframe></iframe>
	</div>
</div>
<iframe src="http://www.google.com/"></iframe>

<script type="text/javascript">
document.body.appendChild(document.getElementById("div1"))
</script>
</body>

Reproducible: Always

Steps to Reproduce:
like the code below:
<body>

<div>   
	<div id="div1">
		<iframe></iframe>
	</div>
</div>
<iframe src="http://www.google.com/"></iframe>

<script type="text/javascript">
document.body.appendChild(document.getElementById("div1"))
</script>
</body>

Comment 1

7 years ago
Created attachment 472248 [details]
testcase

Can't reproduce on 3.6.8, nor on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre

Updated

7 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [WFM?]
Yep.  Worksforme as well.

Reporter, please feel free to reopen if you attach a testcase that shows the problem....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 years ago
Yeah, I encountered once, I'll reproduce it later.
(Reporter)

Comment 4

7 years ago
I find that the bug will appear as you refresh the page.
(Reporter)

Comment 5

7 years ago
Created attachment 472570 [details]
refresh the page, the bug will appear
(Reporter)

Comment 6

7 years ago
Created attachment 472571 [details]
this picture shows the bug. but I don't know how it disappear on this site.
Ah, if you need refresh to reproduce then bug 462076 almost certainly fixed it.  Please try Firefox 4 beta 5?
(Reporter)

Comment 8

7 years ago
Ok, I'll be waiting for Firefox4..!
You need to log in before you can comment on or make changes to this bug.