The default bug view has changed. See this FAQ.

Add "face" to the list of white-listed attributes

VERIFIED FIXED in mozilla2.0b7

Status

()

Core
DOM
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: kevin zhang, Assigned: Ehsan)

Tracking

({fixed-seamonkey2.0.8, regression, verified1.9.2})

Trunk
mozilla2.0b7
x86
All
fixed-seamonkey2.0.8, regression, verified1.9.2
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+, blocking1.9.2 .11+, status1.9.2 .11-fixed, blocking1.9.1 .14+, status1.9.1 .14-fixed)

Details

(Whiteboard: [gs][tb31needed][tb30needed][fixed-tb3.1.4][fixed-tb3.0.8, URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: 3.1.3

I think there is a problem in the beta version of Thunderbird 3.1.3
we use a HTML file as our signature, in the file, we define the fonts should be Calibri, but when we compose Email, the fonts in the signature was turned into another fonts, such as the system default fonts, but the body of the Email can use the user-defined fonts, like Calibri

Reproducible: Always

Actual Results:  
no change


no additional information
(Reporter)

Updated

7 years ago
Version: unspecified → 3.1
Duplicate of this bug: 592600
Joe is this one of our known issues ?

Comment 3

7 years ago
I'm unable to test extensively at the moment (I'm on an interim PC) But this looks like a new issue to me. The Font face tag seems to be removed from the original html file when applied as a sig.

kevin, You could help with this by comparing the message source of your html file with the html in the applied sig.(View>>Message source)

Comment 4

7 years ago
A little further testing on this in 
Mozilla/5.0 (Windows NT 5.0; rv:2.0b5pre) Gecko/20100831 Thunderbird/3.2a1pre ID:20100831032343

There have been some recent changes in Core Editor that most likely is involved in this bug (bug 580442) Certain html tags are now sanitized by the editor, and I guess we should add the "font face" tag to that bug.

A work-around would be to use inline styles in the sig instead of a font tag.
Here's an example that works for me.
<span style="font-family: Comic Sans MS;">JoeS
</span>

This preserves the font selection when used in a signature.
Marking as new although this will probably be determined to be a core bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)
> I'm unable to test extensively at the moment (I'm on an interim PC) But this
> looks like a new issue to me. The Font face tag seems to be removed from the
> original html file when applied as a sig.
> 
> kevin, You could help with this by comparing the message source of your html
> file with the html in the applied sig.(View>>Message source)

Hi Joe, yes, I just compared the html file with the html appied as a sig, the font tag was removed after we applied it as a sig in the mail, only left the font color tag
Thanks
(Reporter)

Comment 6

7 years ago
(In reply to comment #4)
> A little further testing on this in 
> Mozilla/5.0 (Windows NT 5.0; rv:2.0b5pre) Gecko/20100831 Thunderbird/3.2a1pre
> ID:20100831032343
> 
> There have been some recent changes in Core Editor that most likely is involved
> in this bug (bug 580442) Certain html tags are now sanitized by the editor, and
> I guess we should add the "font face" tag to that bug.
> 
> A work-around would be to use inline styles in the sig instead of a font tag.
> Here's an example that works for me.
> <span style="font-family: Comic Sans MS;">JoeS
> </span>
> 
> This preserves the font selection when used in a signature.
> Marking as new although this will probably be determined to be a core bug.

yes, the span tag working, thanks
Component: General → Composition
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Version: 3.1 → Trunk

Updated

7 years ago
Depends on: 580442
OS: Windows XP → All
(Assignee)

Updated

7 years ago
Assignee: nobody → ehsan
Blocks: 520189
blocking1.9.1: --- → ?
blocking1.9.2: --- → ?
blocking2.0: --- → ?
Component: Composition → DOM
No longer depends on: 580442
Keywords: regression
Product: MailNews Core → Core
QA Contact: composition → general
Summary: Problem in the signature → Add "face" to the list of white-listed attributes
(Assignee)

Comment 7

7 years ago
Created attachment 472311 [details] [diff] [review]
Patch (v1)
Attachment #472311 - Flags: review?(bzbarsky)
Attachment #472311 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

7 years ago
Attachment #472311 - Flags: approval2.0?
Doesn't sound like a blocker to me. If it should be, please say why and renominate.
blocking2.0: ? → -

Updated

7 years ago
Attachment #472311 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 9

7 years ago
(In reply to comment #8)
> Doesn't sound like a blocker to me. If it should be, please say why and
> renominate.

I think it should be a blocker, as it is a regression from bug 520189.  For example, if you copy some HTML including a <font face> tag and paste it into an editable field, the face attribute will be lost.
blocking2.0: - → ?
(Assignee)

Comment 10

7 years ago
Created attachment 472682 [details] [diff] [review]
For check-in
Attachment #472311 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Ok, thanks for the clarification! Blocking.
blocking2.0: ? → betaN+
(Assignee)

Comment 12

7 years ago
http://hg.mozilla.org/mozilla-central/rev/c63f70603dd4
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
(Assignee)

Updated

7 years ago
Attachment #472311 - Flags: approval1.9.2.10?
Attachment #472311 - Flags: approval1.9.1.13?
blocking1.9.1: ? → .13+
blocking1.9.2: ? → .10+
status1.9.1: --- → wanted
status1.9.2: --- → wanted
Comment on attachment 472682 [details] [diff] [review]
For check-in

Approved for 1.9.2.10 and 1.9.1.13, a=dveditz for release-drivers
Attachment #472682 - Flags: approval1.9.2.10+
Attachment #472682 - Flags: approval1.9.1.13+
Attachment #472311 - Flags: approval1.9.2.10?
Attachment #472311 - Flags: approval1.9.1.13?
(Assignee)

Comment 14

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/9d4aa3b682a8
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d978f2a4078c
status1.9.1: wanted → .13-fixed
status1.9.2: wanted → .10-fixed
Whiteboard: [gs][tb31needs][tb30needs](?)
Duplicate of this bug: 594360

Comment 16

7 years ago
I also re-imported this on the 1.9.1.12 relbranch as http://hg.mozilla.org/releases/mozilla-1.9.1/rev/1389736dbf5f with permission over IRC from LegNeato. SeaMonkey will take this as a ride-along on our 2.0.8 oilspill release.
Keywords: fixed-seamonkey2.0.8
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> I also re-imported this on the 1.9.1.12 relbranch as
> http://hg.mozilla.org/releases/mozilla-1.9.1/rev/1389736dbf5f with permission
> over IRC from LegNeato. SeaMonkey will take this as a ride-along on our 2.0.8
> oilspill release.

Great!  Maybe Thunderbird could do the same?
Whiteboard: [gs][tb31needs][tb30needs](?) → [gs][tb31needed][tb30needed][fixed-tb3.1.4][fixed-tb3.0.8
Verfifed Fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.9) Gecko/20100910 Thunderbird/3.1.4
Status: RESOLVED → VERIFIED
Keywords: verified-thunderbird3.1
Duplicate of this bug: 595491
Since Ludovic verified this for 1.9.2, adding the 'verified1.9.2' keyword.
Keywords: verified1.9.2
Verified for 1.9.1 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.12) Gecko/20100923 Shredder/3.0.9pre. The face attribute is preserved now in the signature.
You need to log in before you can comment on or make changes to this bug.