Last Comment Bug 592625 - In the Firefox menu clicking sub menu expansion arrows should close the sub-menu
: In the Firefox menu clicking sub menu expansion arrows should close the sub-menu
Status: RESOLVED WONTFIX
[target-betaN]
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 660449 (view as bug list)
Depends on:
Blocks: FirefoxButton 583386
  Show dependency treegraph
 
Reported: 2010-09-01 02:25 PDT by eyal gruss (eyaler)
Modified: 2013-06-20 11:38 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description eyal gruss (eyaler) 2010-09-01 02:25:57 PDT
bookmarks menu in firefox button is hard to reach, as you move the mouse from the firefox button down and right, since the new tab sub menu opens and covers it completely
Comment 1 Johnathan Nightingale [:johnath] 2010-09-14 13:46:40 PDT
A fix would be interesting, and potentially welcome, but this isn't a blocker.
Comment 2 Alice0775 White 2010-09-14 14:05:50 PDT
In Windows7  Start Menu,Clicking > toggle Sub menu.

However, in Firefox Button's Split menu,Clicking > does not toggle Sub menu.

I think that implementation of Windows7 is better.
Comment 3 Alex Faaborg [:faaborg] (Firefox UX) 2010-11-09 12:55:42 PST
>In Windows7  Start Menu,Clicking > toggle Sub menu.

>However, in Firefox Button's Split menu,Clicking > does not toggle Sub menu.

>I think that implementation of Windows7 is better.

I hadn't noticed that, thanks for pointing that out.  I'm changing the focus of this bug to implementing that approach for solving the overall problem.  Otherwise, aside from either changing the entire layout of the menu (to be only vertical) or increasing the timer on hover (which would slow users down), there isn't really any other way to address this problem.
Comment 4 eyal gruss (eyaler) 2010-11-10 13:01:09 PST
alex: is the delay (timer on hover) configurable?
i just tested it on windows 7 with aero, and the delay was longer allowing me to avoid the issue (encountered before on XP classic). i am not sure if this is because aero is slower or because the firefox theme is different.
Comment 5 Alex Faaborg [:faaborg] (Firefox UX) 2010-11-10 18:58:41 PST
I'm not sure if we can configure the delay, cc'ing some people who might know.
Comment 6 Neil Deakin 2010-11-11 04:50:53 PST
On Windows and Linux, this delay is determined by the system setting (On Windows, it is the SPI_GETMENUSHOWDELAY system setting, see http://msdn.microsoft.com/en-us/library/ms724947%28VS.85%29.aspx ) On Mac, it's just 200ms.
Comment 7 Pedro Bessa 2011-05-28 09:04:22 PDT
do like this https://bugzilla.mozilla.org/show_bug.cgi?id=660449
Comment 8 eyal gruss (eyaler) 2011-05-28 09:36:20 PDT
*** Bug 660449 has been marked as a duplicate of this bug. ***
Comment 9 Pedro Bessa 2011-05-29 03:21:37 PDT
"there isn't really any other way to address this problem"

menu:
- new tab
- start private browsing
- ...
- Sync Now
- Exit

sub menu:
- new tab
- new window
- open file

I said make the menu disappear and the sub menu appear where the menu was. Put a back button. Replace the menu with the sub menu. "<". Listen!
Comment 10 Pedro Bessa 2011-05-29 03:22:00 PDT
*put a "<"
Comment 11 Pedro Bessa 2011-05-29 05:02:58 PDT
the user clicks the app button
the app button menu appears with new tab (down arrow)
the user holds mouse over new tab or mouses over down arrow
the down arrow becomes an up arrow
between new tab and start private browsing, the new tab sub menu appears without a second new tab item
Comment 12 Pedro Bessa 2011-05-29 05:04:49 PDT
there is no need to cover bookmarks and history
Comment 13 Pedro Bessa 2011-07-29 02:28:20 PDT
An other way to address this problem:

A click on New Tab shows a submenu on the right side of the app menu with New Window, separator, Open File and without New Tab, so the user learns to click New Tab on the left side of the app button to open a new tab.
If the submenu for New Tab is open, an other click on New Tab runs New Tab (opens a new tab).
A double-click on New Tab does nothing, so the user won't double-click things that are supposed to be only single-clicked.
No arrows for a minimalistic design, because the user doesn't need to know what is to be double-clicked and what is to be single-clicked, just "if I see a submenu that I don't want, I have to click the label again".
Replace New Tab with any other split item in the app menu.
Comment 14 Dão Gottwald [:dao] 2013-05-23 03:31:38 PDT
The Firefox button is going to be removed in bug 863753.

Note You need to log in before you can comment on or make changes to this bug.