Closed Bug 592634 Opened 9 years ago Closed 6 years ago

Unable to open multiple files at once using drag and drop

Categories

(Firefox :: File Handling, defect)

3.6 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 92737

People

(Reporter: alexandru.m.birsan, Unassigned, NeedInfo)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

I was working with a bunch of HTML files and I needed to open about 12 of them in tabs. I selected these and dragged them to the Firefox window, but only the first of the files has been opened when dragging over the tab window (already open page or empty tab). Dragging over the tab bar changes the cursor to "invalid target".

Reproducible: Always

Steps to Reproduce:
1. Copy a few HTML files in a temporary folder, for the purpose of this test.
2. Select all of the HTML files
3. Drag the files and drop them on the Firefox window
Actual Results:  
The first of the files is open, the rest are ignored

Expected Results:  
The first of the file should open in the current tab, the rest in new tabs near the current tab. Also, the software should allow dragging over the tab bar to open new tabs exclusively and at a certain position between tabs.

In Firefox 4 multiple files should be dropped on the panorama view to create a new group of tabs out of those tabs.

Any supported files types (such as image files) should be opened in addition to HTML files.

Workaround: The files can be dropped one by one.
Version: unspecified → 3.6 Branch
I can reproduce this issue with latest Nightly on Win 7 64-bit, by following the STR and also the "multiple files should be dropped on the panorama view to create a new group of tabs out of those tabs" part.

I'm not sure if this is intended or not.  Tim, what do you think?
Flags: needinfo?(fmdevelopertim)
Marked incomplete due to lack of response.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 92737
You need to log in before you can comment on or make changes to this bug.