Closed Bug 592669 Opened 11 years ago Closed 10 years ago

(Tabs On Bottom) Toolbars background should be slightly transparent with use of Aero Glass

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
blocking2.0 --- -
status2.0 --- wanted

People

(Reporter: Terepin, Unassigned)

References

()

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre

See mockup.

Reproducible: Always
Blocks: 568037
blocking2.0: --- → ?
Version: unspecified → Trunk
Peter - you'll notice a trend with the bugs you file around mockup compliance, which is that I tend to cc shorlander and ask whether he thinks, as theme lead, this needs to block. If you did likewise when filing these, it would help us triage your nominations more easily. Please do restrict yourself to those you really feel should block the release when nominating, though -- FF4 is allowed to go out the door looking different than the mockups. It's not allowed to go out the door looking *bad*.

Thanks!
Shorlander - should this block?
blocking2.0: ? → -
status2.0: --- → wanted
(In reply to comment #1)
> Peter - you'll notice a trend with the bugs you file around mockup compliance,
> which is that I tend to cc shorlander and ask whether he thinks, as theme lead,
> this needs to block. If you did likewise when filing these, it would help us
> triage your nominations more easily. Please do restrict yourself to those you
> really feel should block the release when nominating, though -- FF4 is allowed
> to go out the door looking different than the mockups. It's not allowed to go
> out the door looking *bad*.
> 
> Thanks!

Will do. Thanks for the tips!
[ot]So if understood it corectly, the current status of this bug is it isn't blocking of 4.0 release, but eventually it will make it?[/ot]
Attached patch v1 (obsolete) — Splinter Review
Would this be the right way/place to do this?
Attached patch v2Splinter Review
I built with the previous patch and it didn't work, while this seems to do the trick.
Attachment #484547 - Attachment is obsolete: true
Attached image screenshot
And what it looks like in action.

It only seems to take effect when the tabs are on bottom AND the bookmarks toolbar is visible. That's intended, yes?
(In reply to comment #8)
> Created attachment 484606 [details]
> screenshot
> 
> And what it looks like in action.
> 
> It only seems to take effect when the tabs are on bottom AND the bookmarks
> toolbar is visible. That's intended, yes?

Yes.
Can someone from UX team take a look at this, please?

Thank you.
The transparency would disable sub-pixel anti-aliasing, making this a step backwards.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Attachment #484606 - Flags: feedback?(shorlander)
This isn't exactly what I was asking for... ;(
You need to log in before you can comment on or make changes to this bug.