Right-click doesn't work over plugin in background tab

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: smichaud, Assigned: smichaud)

Tracking

({regression, relnote})

Trunk
All
Mac OS X
regression, relnote
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

This bug is related to bug 592563, and has the same regression range.
But unlike bug 592563, this bug happens in both Carbon event mode and
Cocoa event mode.

Steps to reproduce:

1) Start a recent Minefield nightly and load a plugin -- for example
   http://www.playercore.com/bugfiles/146162/AddReturnHTML.html, which
   fills the entire page's width, and its height down to just below
   the last line of text.

2) Open a new tab and switch to it.

3) Right-click in the area that used to be filled by the plugin in the
   first tab -- you'll find that nothing happens.

   Now right-click toward the bottom of the page (in an area not
   filled by the first tab's plugin) -- you'll see a normal context
   menu.

As with bug 592563, the regression range is:

2010-08-27-03-mozilla-central
2010-08-28-03-mozilla-central

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2010-08-27+03%3A00%3A00&enddate=2010-08-28+03%3A00%3A00

And in that range the bug is triggered by the following patch:

changeset:   51636:7804b5cf4313
user:        Robert O'Callahan <roc@ocallahan.org>
date:        Fri Aug 27 18:15:08 2010 -0500
summary:     Bug 130078. Part 2. Remove widgets from all subframes. r=dbaron

http://hg.mozilla.org/mozilla-central/rev/7804b5cf4313
(Assignee)

Comment 1

8 years ago
I'm not able to reproduce this bug on Windows (with today's nightly), so presumably it's OS-X-only.
(Assignee)

Comment 2

8 years ago
This should probably at least block the final release.
blocking2.0: --- → ?
(Assignee)

Comment 3

8 years ago
Another related bug -- bug 592453.
(Assignee)

Updated

8 years ago
Keywords: regression
Keywords: relnote
Josh, sounds like something for you, but please reassign if someone else should dig in here.
Assignee: nobody → joshmoz
blocking2.0: ? → final+
(Assignee)

Comment 5

8 years ago
This bug (bug 592691), bug 592563 and bug 592453 all have the same
trigger point -- the patches for bug 130078 (see comment #0 above).
So it's possible they all have the same cause.

I'm currently working bug 592453 (while also keeping an eye on the
other bugs in this group).  With luck I'll find a single solution for
them all.

Comment 6

8 years ago
-> smichaud for now
Assignee: joshmoz → smichaud
Duplicate of this bug: 593087
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

8 years ago
I've got a patch for this bug (and a tryserver build) at bug 592563 comment #21.
(Assignee)

Comment 9

8 years ago
Fixed by my patch for bug 592563, which just landed on the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.