If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

double-click on column headers goes to selected items, tries to open

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Daniel B., Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.11) Gecko/20100701 SeaMonkey/2.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.11) Gecko/20100701 SeaMonkey/2.0.6

In the Download Manager window, if you have some line in the table selected
and double-click on a column headers, the two clicks are dispatched to
both the column header _AND_ the body of the table--the column sort order
changes twice (as expected), and the file represented by the current
row selection is opened.

Reproducible: Always

Steps to Reproduce:
1. In the Download Manager window ...
2. Select some line
3. Click twice quickly on a column header (e.g., "Name")
4. Note that the column sort order changes twice ...
Actual Results:  
5. ... and that the selected line is "opened" (the file represented by
that selected line is opened)

Expected Results:  
5. ... and nothing else happens.

SeaMonkey 1.1.x used to have a similar type of problem if you middle-clicked
on a mail composition window's scrollbar--the click would scroll but would
also paste into the text.

Comment 1

7 years ago
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100902 SeaMonkey/2.1b1pre

5. ... and that the selected line isn't open.
I can reproduce this with 2.0.x but not on trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → SeaMonkey 2.0 Branch

Comment 3

7 years ago
Only security and stability updates are allowed on the SeaMonkey 2.0.x branch.
Since this is working on trunk, closing as WONTFIX/WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.