Last Comment Bug 592827 - Support DOMImplementation.createHTMLDocument
: Support DOMImplementation.createHTMLDocument
Status: RESOLVED FIXED
[parity-webkit][parity-opera][parity-IE]
: html5
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: P1 enhancement (vote)
: mozilla2.0b7
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
http://www.whatwg.org/html/#dom-domht...
: 33871 232698 (view as bug list)
Depends on: 594767
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-01 13:16 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2010-10-16 12:23 PDT (History)
5 users (show)
dao+bmo: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (9.42 KB, patch)
2010-09-01 13:16 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v2 (9.79 KB, patch)
2010-09-02 02:13 PDT, :Ms2ger (⌚ UTC+1/+2)
jonas: review+
jonas: approval2.0+
Details | Diff | Splinter Review
Patch for checkin (9.88 KB, patch)
2010-09-03 00:47 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2010-09-01 13:16:11 PDT
Created attachment 471249 [details] [diff] [review]
Patch v1

So, are our APIs *worse* than DOM Core or did I just look over the sane one?
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2010-09-01 13:30:22 PDT
nsIDocument::CreateElem?
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2010-09-02 02:13:46 PDT
Created attachment 471444 [details] [diff] [review]
Patch v2

This looks a bit better already. It seems like other consumers of use nsAtomString, should I do the same?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2010-09-03 00:47:06 PDT
Created attachment 471777 [details] [diff] [review]
Patch for checkin

Thanks!
Comment 4 Dão Gottwald [:dao] 2010-09-04 04:42:55 PDT
http://hg.mozilla.org/mozilla-central/rev/62e97e282725
Comment 5 Eric Shepherd [:sheppy] 2010-09-16 06:33:39 PDT
Removing the doc needed flag; will be following bug 594767 to track readiness to document this the rest of the way.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2010-10-16 12:05:43 PDT
*** Bug 33871 has been marked as a duplicate of this bug. ***
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2010-10-16 12:23:17 PDT
*** Bug 232698 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.