Closed Bug 592861 Opened 9 years ago Closed 9 years ago

Links in scrollable divs change color when scrolling

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: u88484, Unassigned)

References

()

Details

(Keywords: regression, testcase, Whiteboard: [fixed by Bug 579276])

Attachments

(1 file)

Attached file Reduced testcase
Links in scrollable divs change color when you scroll inside the div.

STR:
1) Load the attached test case
2) Notice how the links are gray
3) Scroll using the divs scrollbar

Links turn from gray to green when scrolling happens in a new profile.  I have d2d disabled on my other profile so it is not caused by that and this is a regression from Firefox 3.6

I see this issue on facebook when scrolling through chats and in the URL above.
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
* reproducable on Windows XP too
* this regressed between Beta 1 <-> 2 by a quick Check
Should be fixed when 579276 lands, yes.
Depends on: 579276
Indeed this is fixed by Checkin Of Bug 579276 tested by using a Build built from http://hg.mozilla.org/mozilla-central/rev/4b879b793eb6.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [fixed by Bug 579276]
Verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.