[Mac] Trying to "Save as PDF" or Print a document temporarily corrupts page

RESOLVED DUPLICATE of bug 592405

Status

()

RESOLVED DUPLICATE of bug 592405
8 years ago
8 years ago

People

(Reporter: marcia, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [4b5])

Attachments

(1 attachment)

Seen on two different 10.6 machines while testing Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

STR:
1. Load a bug page, such as https://bugzilla.mozilla.org/show_bug.cgi?id=592829
2. File->Print->PDF->Save as PDF
3. Name the document and Press the Save button
4. Observe the rendering of the page

It temporarily loses all of its styling and looks like an HTML page. As soon as I move my mouse to take a screenshot the page is restored to its normal state.
Created attachment 471325 [details]
Screenshot of one page where this happened

I was able to grab a screenshot of this page before it went back to normal.
This happens using 10.5 as well, and on the latest Mac trunk nightly.
Summary: Trying to "Save as PDF" temporarily corrupts page → [Mac] Trying to "Save as PDF" temporarily corrupts page
Doesn't have to be a PDF - it happens when simply printing a document.
blocking2.0: --- → ?
Summary: [Mac] Trying to "Save as PDF" temporarily corrupts page → [Mac] Trying to "Save as PDF" or Print a document temporarily corrupts page
Dbaron saw some weirdness like this too, iirc.
I went back to  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 and I don't see this issue when printing.
Sounds like it is a dupe, but the issue is much worse on the Mac than it is on Windows, where I have trouble seeing it. On the mac, when printing is done, I have to make a mouse movement in order to get the normal page to render properly.

(In reply to comment #6)
> Probably duplicate of bug 592405?
(In reply to comment #7)
> Sounds like it is a dupe, but the issue is much worse on the Mac than it is on
> Windows, where I have trouble seeing it.

bug 592405 is very obvious & broken-looking on Linux, FWIW (using dbaron's STR on that bug).
Bug 592405 landed. Please try tomorrow's nightly (2010-09-06) to see if this is fixed.
Please confirm whether this is fixed on trunk!
blocking2.0: ? → final+
I can confirm that I am no longer seeing this issue using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100920 Firefox/4.0b7pre.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592405
(Reporter)

Updated

8 years ago
Keywords: regression, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.