Web Console allows selection in both the output box and the input box

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 months ago

People

(Reporter: pcwalton, Assigned: pcwalton)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
STR:
1. Open the Web Console.
2. Reload a page so that some messages appear in the console.
3. Enter text in the input box.
4. Select text from the output box.
5. Click in the output box.

Notice that the selection doesn't go away. I believe that this is due to the output node not being focusable (cf. Neil's comments in bug 592309).
(Assignee)

Comment 1

8 years ago
Created attachment 471658 [details] [diff] [review]
Proposed patch.

Proposed patch attached.

Unfortunately, I had difficulty reproducing this in a unit test. Selecting the children of the node using window.getSelection().selectAllChildren(outputNode) and then simulating a click in the text field always works even without the patch, even though this is not what happens when the user clicks and drags. Suggestions/feedback welcome.
Assignee: nobody → pwalton
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Attachment #471658 - Flags: feedback?(ddahl)
(Assignee)

Comment 2

8 years ago
Created attachment 471662 [details] [diff] [review]
Proposed patch, version 2.

Mistakenly uploaded an incorrect version of the patch. New patch attached.
Attachment #471658 - Attachment is obsolete: true
Attachment #471662 - Flags: feedback?(ddahl)
Attachment #471658 - Flags: feedback?(ddahl)

Updated

8 years ago
Whiteboard: [kd4b7]

Comment 3

8 years ago
I'm unable to reproduce this in a nightly...

Updated

8 years ago
Whiteboard: [kd4b7]

Comment 4

8 years ago
I think the re-skin fixed this. Closing WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Attachment #471662 - Flags: feedback?(ddahl)

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.