Don't export libxpconnect.so for unsupported platforms

RESOLVED FIXED

Status

SeaMonkey
Build Config
P3
normal
RESOLVED FIXED
19 years ago
13 years ago

People

(Reporter: Chris McAfee, Assigned: Brian Ostrom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From bug http://bugzilla.mozilla.org/show_bug.cgi?id=5661.

Let Solaris and other non-supported platforms fail xptcall
gracefully by simply not exporting libxpconnect.so for those
platforms.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 1

19 years ago
Hey, I already did this. See my comment in...
http://bugzilla.mozilla.org/show_bug.cgi?id=5661
...and my attachment...
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=122

So now makeing xpconnect work on a Unix platform means doing the xptcall port
and also jiggering this Makefile.in to export the libxpconnect to the components
dir on that platform. Soon this will be moot cuz mozilla won't be able to fail
gracefully without a fully functioning xptcall anyway.
(Reporter)

Comment 2

19 years ago
Ah, Ok. Thanks :-)

QA: This is a work-around bug, you can test this by
seeing if "Solaris starts up and doesn't crash immediately".
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.