If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ nsTArray<JSContext*>::IndexOf<JSContext*, nsDefaultComparator<JSContext*, JSContext*> >(JSContext* const&, unsigned int, nsDefaultComparator<JSContext*, JSContext*> const&) ]

RESOLVED DUPLICATE of bug 593273

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 593273
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100903 Firefox/4.0b6pre

This is a new crash signature that has been introduced by this build.
It is #1 TOP crasher for this build.
One comment says : "ie9 fishtank demo with layers.accelerate.all true"
But it happens also with layers.accelerate.all set to false.

Signature	nsTArray<JSContext*>::IndexOf<JSContext*, nsDefaultComparator<JSContext*, JSContext*> >(JSContext* const&, unsigned int, nsDefaultComparator<JSContext*, JSContext*> const&)
UUID	ee03431d-799b-43f1-9a3e-124ae2100903
Time 	2010-09-03 08:39:37.937509
Uptime	6107
Last Crash	78085 seconds (21.7 hours) before submission
Install Age	7968 seconds (2.2 hours) since version was first installed.
Product	Firefox
Version	4.0b6pre
Build ID	20100903040836
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x4
User Comments	
App Notes 	AdapterVendorID: 8086, AdapterDeviceID: 2a42
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsTArray<JSContext*>::IndexOf<JSContext*,nsDefaultComparator<JSContext*,JSContext*> > 	obj-firefox/dist/include/nsTArray.h:413
1 	xul.dll 	nsTArray<nsGeolocation*>::RemoveElement<nsGeolocation*,nsDefaultComparator<nsGeolocation*,nsGeolocation*> > 	obj-firefox/dist/include/nsTArray.h:739
2 	xul.dll 	mozilla::layers::ThebesLayerD3D9::~ThebesLayerD3D9 	gfx/layers/d3d9/ThebesLayerD3D9.cpp:60
3 	xul.dll 	mozilla::layers::ThebesLayerD3D9::`vector deleting destructor' 	
4 	xul.dll 	mozilla::layers::Layer::Release 	obj-firefox/dist/include/Layers.h:398
5 	xul.dll 	mozilla::layers::ContainerLayerOGL::RemoveChild 	gfx/layers/opengl/ContainerLayerOGL.cpp:110
6 	xul.dll 	mozilla::layers::ContainerLayerD3D9::~ContainerLayerD3D9 	gfx/layers/d3d9/ContainerLayerD3D9.cpp:53
7 	xul.dll 	mozilla::layers::ContainerLayerD3D9::`scalar deleting destructor' 	
8 	xul.dll 	mozilla::layers::Layer::Release 	obj-firefox/dist/include/Layers.h:398
9 	xul.dll 	mozilla::layers::LayerManagerD3D9::`vector deleting destructor' 	
10 	xul.dll 	gfxFontEntry::Release 	
11 	xul.dll 	nsXULWindow::Destroy 	xpfe/appshell/src/nsXULWindow.cpp:555
12 	xul.dll 	nsWebShellWindow::Destroy 	xpfe/appshell/src/nsWebShellWindow.cpp:795
13 	xul.dll 	nsWebShellWindow::HandleEvent 	
14 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3505
15 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3543
16 	xul.dll 	nsWindow::DispatchStandardEvent 	widget/src/windows/nsWindow.cpp:3536
17 	xul.dll 	xul.dll@0x4ec449 	
18 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4319
19 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:4271

The regression range is :
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dc2939f2640d&tochange=4b879b793eb6
http://tinyurl.com/2btx435 links to all the crashes.

I was able to repro by going to about:config and then changing layers.accelerate.all to true.

https://crash-stats.mozilla.com/report/index/4fb8b39b-5960-4e3d-a324-904072100903 is my report.

A side effect of this bug is that you get a blank Minefield quit dialog when you try to exit.
The blank Minefield quit dialog is bug 593272. This bug is a dupe of bug 593273.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593273
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsTArray<JSContext*>::IndexOf<JSContext*, nsDefaultComparator<JSContext*, JSContext*> >(JSContext* const&, unsigned int, nsDefaultComparator<JSContext*, JSContext*> const&) ]
You need to log in before you can comment on or make changes to this bug.