App tabs notify even if title is set but not changed

RESOLVED FIXED in Firefox 4.0b7

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Brian Polidoro, Assigned: dao)

Tracking

Trunk
Firefox 4.0b7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 471947 [details]
testcase that sets the title to the same thing every 5 seconds

I see the notification of a title change when I use Yahoo Mail as an app Tab.  But the title hasn't changed.  (I still have zero new messages.)

To me it seems like Yahoo Mail always sets the title when it checks the server for new messages.  And even if the new title is the same as the old title the notification gets triggered.  

I'm attaching a testcase to prove that.  

1. Load it 
2. make it an App Tab
3. switch to another tab.

Expected:
No notification since the title is not changing.  It is being set to the same string.

Actual:
The App tab notifies that the title changed.  

I heard other things like Google Reader also does the same thing.

Comment 1

7 years ago
Nominating as a blocker, given that the original bug was a blocker, and the original bug as filed is not actually fixed (fixed as in doing what was intended originally - I understand that code was changed).
blocking2.0: --- → ?
(Assignee)

Updated

7 years ago
Assignee: nobody → dao
(Assignee)

Comment 2

7 years ago
Created attachment 472139 [details] [diff] [review]
patch
Attachment #472139 - Flags: review?(gavin.sharp)
Comment on attachment 472139 [details] [diff] [review]
patch

You could change the setAttribute("crop") to use .crop.

Seems like ideally this would be done at a lower level (i.e. avoid firing DOMTitleChanged entirely in this case), but it's harder to evaluate the compatibility effects that could have. File a followup?
Attachment #472139 - Flags: review?(gavin.sharp) → review+
blocking2.0: ? → final+
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 4

7 years ago
(In reply to comment #3)
> Seems like ideally this would be done at a lower level (i.e. avoid firing
> DOMTitleChanged entirely in this case), but it's harder to evaluate the
> compatibility effects that could have.

I actually looked into this, but it seemed to me that title_window.xul depended on the current behavior. Now that I look at it again, maybe it doesn't.
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/72a4ec3eabf2
http://hg.mozilla.org/mozilla-central/rev/7dd97a6a7ff6

filed bug 593623
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
(Assignee)

Updated

7 years ago
Depends on: 593626

Comment 6

7 years ago
Was this supposed to break notifications on gmail?  The title is updated each time a new email is received but now I'm not notified with the red glow.
(Assignee)

Comment 7

7 years ago
(In reply to comment #6)
> Was this supposed to break notifications on gmail?  The title is updated each
> time a new email is received but now I'm not notified with the red glow.

I don't know what Gmail is exactly doing. Please file a new bug.

Comment 8

7 years ago
It's the same with yahoo mail.

Updated

7 years ago
Blocks: 593836
(Assignee)

Updated

7 years ago
No longer depends on: 593626

Updated

7 years ago
Depends on: 594391
You need to log in before you can comment on or make changes to this bug.