the system doesn't handle correctly the nicknames contain non7bit characters

RESOLVED DUPLICATE of bug 416966

Status

Other Applications
ChatZilla
RESOLVED DUPLICATE of bug 416966
8 years ago
8 years ago

People

(Reporter: hunboy, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: ChatZilla 0.9.86 [Firefox 3.0.3/2008092417]

sample:
[13:20]	-->|	úser ((null)@(null)) has joined #csati
[13:20]	<--|	úser has left #csati
after joining user with national characters, his mask is failed both of variables contain null value.
after leaving this user, the userlist doesn't updated, the user stays on the list, although user already left. (not every time, sometimes leaving correctly)
sometimes doesnt show his leaving mark

character encoding in set for chatzilla is UTF-8

Reproducible: Always

Steps to Reproduce:
1. join a room from other client, perhaps mirc with nickname contains non7bit character
2. leave the room with that client
3. view the join/part messages
Actual Results:  
after joining user with national characters, his mask is failed both of variables contain null value.
after leaving this user, the userlist doesn't updated, the user stays on the list, although user already left. (not every time, sometimes leaving correctly)
sometimes doesnt show his leaving mark


Expected Results:  
show correctly the mask for user, update correctly the userlist
(Reporter)

Comment 1

8 years ago
After clicking to a nick contains non7bit character, the queryview opens with this message:

The nickname “úser” does not exist.

Comment 2

8 years ago
IRC doesn't have any concept of characters; if you don't set your client to the same as others on the server (sometimes channel), things will go wrong.

Comment 3

8 years ago
(And this is probably at best just a duplicate of bug 416966.)(
(Reporter)

Comment 4

8 years ago
i wrote that bug ,only similar problem but maybe not same. 
this current is relate to nicknames, and not channelnames.
(as I wrote the channelname problem was fixed).

the most weird behaviors are in my first message.
like this : úser ((null)@(null)) has joined #csati
these null values in mask show only with non7bit-nicknames

i tested with mirc also,
that opens correctly query for non7bit-character-nicknames
(Reporter)

Comment 5

8 years ago
I meant: 'I have read that bug'

Tested in UTF-8 and in ISO-8859-2
---
when it is in UTF-8 mode, it shows this:

úser ((null)@(null)) has joined #room

and shows leaving the room correctly almost every time.
quit the server is buggy in this case, user stays on the list, although done for a while. I need leave the room and rejoin to make clean the userlist in this case.
---
when it is in ISO-8859-2 mode, it shows this:

úser (test@87.97.111.219.pool.invitel.hu) has joined #room

so looks good, parting, quiting looks ok
---
but both of cases PrivMSG does NOT work at all, says:
The nickname “úser” does not exist.

same situation in ISO-8859-1 mode also.
(Reporter)

Comment 6

8 years ago
let's continue at the old one, maybe same issue, as I took a short look to source, seems maybe unicodeName makes the troubles currently (in my fast opinion only, maybe wrong).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416966
You need to log in before you can comment on or make changes to this bug.