Closed Bug 593613 Opened 9 years ago Closed 9 years ago

[SeaMonkey 2.1] debug test mochitests-2/5 : test_bug590573.html intermittently times out

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 593144

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

518 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/test_bug590573.html | Test timed out.
Where there has been intermittent time outs before some have been resolved by calling SimpleTest.finish from setTimeout, not sure if that is the correct approach here though.
Attachment #472175 - Flags: review?(jbalogh)
Fwiw, TopFails doesn't list this failure (FF, FF3.6, SM) :-<
Depends on: 565307
Comment on attachment 472175 [details] [diff] [review]
Call SimpleTest.finish from setTimeout

This is not the reviewer you're looking for.
Attachment #472175 - Flags: review?(jbalogh)
Comment on attachment 472175 [details] [diff] [review]
Call SimpleTest.finish from setTimeout

SimpleTest.executeSoon(SimpleTest.finish);

if this will even help of course. :-)
Attachment #472175 - Flags: feedback-
IanN, ping. Needs a new reviewer!
Comment on attachment 472175 [details] [diff] [review]
Call SimpleTest.finish from setTimeout

Any better suggestions welcome.
Attachment #472175 - Flags: review?(justin.lebar+bug)
This is a dupe of bug 593144, right?

Ian, can you point me to bug where calling SimpleTest.finish() from within a setTimeout(0) fixed a randomorange?  I'm happy to try this, but I'd like to understand why it might work.

I have a wild guess of a patch up in bug 593144, fwiw.  But this one is much smaller.  :)
Attachment #472175 - Flags: review?(justin.lebar+bug)
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593144
V.Duplicate, per previous comments.
No longer blocks: SmTestFail
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.