Closed Bug 593615 Opened 10 years ago Closed 9 years ago

Resizing Gadget in Google Docs is broken

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sylvain.pasche, Unassigned)

References

()

Details

Steps to reproduce:
 1. Open a Google document which contains a Gadget. You can do this by going there: https://spreadsheets.google.com/ccc?key=pnLDJiBKx5IjdzAzTgDqjSg&newcopy&pli=1
 2. Click on the Gadget and try to resize it.

Result:
When you release the mouse button, the resize operation doesn't stop and moving your mouse around is still resizing the Gadget.

Expected:
Releasing the mouse button should stop the resizing operation.

This works fine in Firefox 3.6, but is broken in 4.0 beta or Minefield.
Doing a quick Check, this regressed between Alpha 5 <-> Beta 1.
This regressed within:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9c85f9aaec8c&tochange=0e0e2516f04e

Delta of Error Console Output of those two Builds:
Error: Missing query for request id: 0
Source file: http://www.google.com/uds/api/visualization/1.0/1c8f076799d869be19b4130aadbaa93e/default,motionchart+de.I.js
Line: 273

Line 273:
P.Wl=function(){var a=this.wb;if(/\.google\.com:433/[ib](a))a=a[z](/\.google\.com:433/,Rn);this.wb=a};function Sn(a){if(a[H].yf()){a=cf(a[H].Ak());if(a[pc](/^({.*})$/)){a=Ve(a);Tn(a)}else we(We(a))}else e(l("google.visualization.Query: "+a[H].uk()))}function Tn(a){var b=a.reqId,c=Mn[b];if(c){Mn[b]=i;c.Fd(a)}else e(l("Missing query for request id: "+b))}P.Xd=i;P.Wd=i;P.pe=i;P.Ra=i;P.lf=i;P.ic=i;P.If=h;P.pc=0;P.Af=i;P.sa=k;
blocking2.0: --- → ?
Product: Firefox → Core
QA Contact: general → general
I see that error even on some builds on which this bug seems to not appear....  Someone needs to bisect this.  :(
My preliminary bisect suggests:

The first bad revision is:
changeset:   46389:0483e52295f6
parent:      46385:d08120d3792e
user:        Nick Thomas <nthomas@mozilla.com>
date:        Tue Jun 29 15:09:55 2010 +1200
summary:     Bug 570022, bump Firefox/Gecko version to 4.0b2pre/2.0b2pre after 4.0b1 tagging, r=jhford, a=beltzner, CLOSED TREE

but this stuff is all pretty much broken in all the builds I tried, so it's hard to say.
blocking2.0: ? → betaN+
So just to check.. if you
Keywords: qawanted
I also don't see the gadget show up at all on trunk, even if I spoof the fx3.6 UA.
Replacing the UA of the Alpha 5 Build with a Trunk UA, the Resizing keeps working.

So this seems not to be a UA Sniffing Thingy, but rather a (wrong) Feature Sniffing Issue or a real Gecko Bug, no?
Right.  The question is when it broke.  I suppose I should try bisecting again...
For what it's worth, the "good" builds on Linux never show the gadget (though the resizing works).

On Mac, the "bad" builds at the end of the range do show the gadget, but trunk does not.  So something else has gone wrong too, apparently.
I just redid the bisection, and I get the same thing as in comment 4.
OK, if I take a build from changeset 0483e52295f6 on Linux, it does show the resizing problem.  If I then change its UA string to "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a6pre) Gecko/20101207 Minefield/2.0b2pre" then the resizing starts to work.

So clearly there _is_ broken UA sniffing going on on the Google side.

Furthermore, if I take a current trunk Mac build (which does show the bug as filed) and then set its UA to the above string, then _resizing_ starts to work.  The gadget still doesn't load, of course, but that has a different regression range.

So the resizing issue looks like tech evang to me.
Assignee: nobody → english-us
Blocks: 570022
blocking2.0: betaN+ → ---
Component: General → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
As it seems the Sniffing Function doesn't like the "rv:2.0b8pre" Part of the current UA.
If i replace that one with "rv:1.9.3a6pre" everything works as expected on WinXP.
Should have caught this when making Comment 2 ...
A new version of Google Spreadsheets was released last week which fixed this issue.  I verified the fix in Minefield 4.0b11pre (2011-01-26).
Thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.