Scrolling the mouse wheel over the tabs does not switch tabs

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

4.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre

Tabs should be switched while scrolling over them.
This is normal behavior of GTK+ application, for example Nautilus.

This is probably related to bug #281192.

If this bug is considered as valid (and I hope so), it should block 4.0.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 572482

Comment 1

8 years ago
The difference is that on nautilus, most people don't have so much tabs they overflow. I understand that it seems natural to switch tab when scrolling on tabs when they are visible. But when I want to switch to a tab that is hidden, I don't want to have to switch to every single tab between my two tabs... I just want to see the other tab. 

Would it be logic to scroll the ribbon of tabs when the tabs overflow, but switch to next/prev tab when the tab bar is static? It would be a good compromise, I believe.
(In reply to comment #1)
> Would it be logic to scroll the ribbon of tabs when the tabs overflow, but
> switch to next/prev tab when the tab bar is static? It would be a good
> compromise, I believe.

There was a patch in bug 281192 that did this.

Comment 3

8 years ago
For me, the situation is this: In FF3.6, scrolling the mouse wheel switches tabs. It does that for a while and I got quite used to it. In FF4b6, this doesn't work any more.
Was it an undocumented (unintendet) feature or is the current situation a regression.
For me, the discussion doesn't really involve gnome/gtk.
(In reply to comment #3)
> For me, the situation is this: In FF3.6, scrolling the mouse wheel switches
> tabs. It does that for a while and I got quite used to it. In FF4b6, this
> doesn't work any more.

It's not supposed to work in Firefox 3.6. I bet an add-on made it work for you, be it intentionally or unintentionally.
(In reply to comment #4)
> (In reply to comment #3)
> > For me, the situation is this: In FF3.6, scrolling the mouse wheel switches
> > tabs. It does that for a while and I got quite used to it. In FF4b6, this
> > doesn't work any more.
> 
> It's not supposed to work in Firefox 3.6. I bet an add-on made it work for you,
> be it intentionally or unintentionally.

It's supposed to scroll the tab bar if there isn't enought place to show all tabs. If this is broken (without any addon on your profile ;-)), please fill a new bug and ask for 2.0 blocking.

Comment 6

8 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > It's not supposed to work in Firefox 3.6. I bet an add-on made it work for you,
> > be it intentionally or unintentionally.

Indeed. Turns out it was the FireGestures addon which provided the functionality. As of now, it's incompatible with FF4.

> It's supposed to scroll the tab bar if there isn't enought place to show all
> tabs.

This part is working. Thanks for clearing things up!

Updated

8 years ago
Version: unspecified → 4.0 Branch

Comment 7

8 years ago
Strictly speaking, if you don't intend to change the behaviour, this is NOTABUG (?)

Comment 8

6 years ago
Is this a duplicate of bug 281192?

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Duplicate of this bug: 969789
You need to log in before you can comment on or make changes to this bug.