Accents shifted one character to the right

UNCONFIRMED
Unassigned

Status

()

--
trivial
UNCONFIRMED
8 years ago
5 hours ago

People

(Reporter: victor.engmark, Unassigned)

Tracking

3.6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

This is bizarre - Accents (`, ´)on this web page are shown over the next character.

It's not a feature of the markup. If you try to copy the text to another application, it shows up with the right accents.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 472245 [details]
Screenshot of web site with bug

Comment 2

8 years ago
looks ok to me w/ a ff4.0b6 nightly on osx...

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 3

2 years ago
Had similar issue with form that consistently showing accented e with accent next to it, however when typed in into form it worked fine.

Looking at DOM for difference with two different form elements there was a one-byte difference in length of the text (42 vs 43) even though Firebug displayed both strings identical and copying string into other apps also showed them identical.

Researching the hex values the values where coming from tracked it down to different UTF-8 encodings of the characters, explaining the extra byte. 

Properly displayed encoding is: C3 A9
Improperly displayed encoding is: 65 CC 81

Firefox displays the 65 CC 81 as two characters rather than combining it properly. Other browsers I tested (Safari) does properly display both encodings as an accented character.

While Firefox should display this correctly too, ultimately it needs to be fixed in the encoding. In my case the application still fails because the database treats these two values as not equal causing other problems.

Comment 4

2 years ago
For more detail: http://www.utf8-chartable.de/unicode-utf8-table.pl?start=768 and http://www.fileformat.info/info/unicode/char/0301/index.htm and http://unicode.org/faq/char_combmark.html

This encoding falls into the 'non-spacing' or 'combining' character class. Appears that Firefox is not honoring this Unicode character class properly when rendering text, but rather treating it as separate characters. 

It's properly displayed when copying it anywhere else because of a change in rendering path.

Comment 5

5 hours ago
I think I have this problem in https://habbo.com

I noticed that it would only and ALWAYS happen when I tried to put an accent on a vowel quickly. It doesn't happen outside that chat and also does not happen on other browsers (tested with Edge). It's pretty frustrating.
You need to log in before you can comment on or make changes to this bug.