Awesome Bar search handling change

RESOLVED DUPLICATE of bug 593709

Status

()

defect
RESOLVED DUPLICATE of bug 593709
9 years ago
9 years ago

People

(Reporter: piperapk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100905 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100905 Firefox/4.0b6pre

Awesome bar search now directs to a Google search page, like if searching through the search bar, instead to a site directly. I think it's not necessary to have the same function on two different places and would be better to revert back the search method of the Awesome bar

Reproducible: Always



Expected Results:  
Direct to the site instead of a Google search results.

Comment 1

9 years ago
That's the "Browse by Name" feature, which existed before (and which wa doen by Google, not your browser). You only go direct to the site, if Google is sure that it's the correct one, otherwise you see the search results, so you have to click on the correct link (not necessarily the first). A kind of safer version of the the "I'm feeling lucky" search.

http://kb.mozillazine.org/Location_Bar_search

In Firefox 4.0, the "Browse by name" will be turned off though, so you always see the search results. See bug 565966.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565966
Jo, marking a bug complaining about a regression a duplicate of the bug that caused the regression doesn't make any sense.
Duplicate of bug: 593709
You need to log in before you can comment on or make changes to this bug.