Tabview button and other toolbarbuttons increase the tab bar height

RESOLVED FIXED in Firefox 4.0b7

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 4.0b7
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.35 KB, patch
ventnor.bugzilla
: review+
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
Created attachment 472271 [details] [diff] [review]
patch

see bug 593570 comment 2
Attachment #472271 - Flags: review?(gavin.sharp)
(Assignee)

Updated

8 years ago
Blocks: 594013
(Assignee)

Updated

8 years ago
Duplicate of this bug: 594201
(Assignee)

Updated

8 years ago
Blocks: 595286
(Assignee)

Updated

8 years ago
Blocks: 58901
No longer blocks: 595286
(Assignee)

Updated

8 years ago
Blocks: 589010
No longer blocks: 58901
Dāo, does the Panorama button still do this with the latest version of bug 589010?
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> Dāo, does the Panorama button still do this with the latest version of bug
> 589010?

Yes.
Fixing this will most likely also fix bug #594013, because currently the app tabs look fine as long as there is no action button added to the tab bar (like tab candy etc)

This goes even further as explained in bug #594922 which has a lot of dupe information but issue a is still valid after this patch I think. Maybe also the persona issue.
(Assignee)

Comment 5

8 years ago
Created attachment 474356 [details] [diff] [review]
patch

updated to tip
Attachment #472271 - Attachment is obsolete: true
Attachment #474356 - Flags: review?(gavin.sharp)
Attachment #472271 - Flags: review?(gavin.sharp)
(Assignee)

Updated

8 years ago
Attachment #474356 - Flags: review?(ventnor.bugzilla)

Updated

8 years ago
Attachment #474356 - Flags: review?(ventnor.bugzilla) → review+
(Assignee)

Updated

8 years ago
Attachment #474356 - Flags: review?(gavin.sharp) → approval2.0?
Tested the patch, does what it says and also fixes bug #594013. I will update #594922 accordingly.
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/d90e28f6e38f
Blocks: 593967
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
(Assignee)

Updated

8 years ago
Attachment #474356 - Flags: approval2.0?
You need to log in before you can comment on or make changes to this bug.