If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird should close window after deleting last message in folder

RESOLVED DUPLICATE of bug 505604

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 505604
7 years ago
7 years ago

People

(Reporter: Sara Uckelman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7
Build Identifier: 3.1.2

Description of problem: In previous versions of Thunderbird, when a message in
an open window was deleted, the next message opened up in the same window
*unless* the message deleted was the last message in a folder.  Now, when the
last message in a folder is deleted, the window opens up the previous message. 
This may or may not be a bug, but if there's a way to set things so that this
doesn't happen, and the expected behavior from earlier versions of Thunderbird
is produced, I can't find the preference/setting anywhere.

Version-Release number of selected component (if applicable):
thunderbird-3.0-2.8.b4.fc11.x86_64

How reproducible: Every time.

Steps to Reproduce:
1. Open message.
2. Delete message.
3. Continue deleting until you've deleted the final message in a folder.

Actual results:

The new last message in the folder opens in the window.

Expected results:  The window should close.




Reproducible: Always

Steps to Reproduce:
1. Open message
2. Delete message
3. Continue deleting until you've deleted the last message in a folder.
Actual Results:  
The new last message in the folder opens in the window.


Expected Results:  
The window should close.

This bug has previously been reported in fedora's bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=529434
(In reply to comment #0)
> Build Identifier: 3.1.2
[snip]
> Version-Release number of selected component (if applicable):
> thunderbird-3.0-2.8.b4.fc11.x86_64

So what version are you reporting this against ? 3.0.2 or 3.1.2 ?

What was the previous version of Thunderbird you were using ?

Does it work better if you start Thunderbird in -safe-mode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode)?
(Reporter)

Comment 2

7 years ago
The problem started in 3.0.2, and continues in 3.0.3 and 3.1.2.  At the office, I am using 2.0.0.19, and the problem does not occur there (it also did not occur in pre-3.0.2 versions).
Whiteboard: dupme

Comment 3

7 years ago
The problem is still there in 3.1.4.

The problem is particularly annoying if you sort the mail in your folders such that the most recent message is at the bottom.  When a new email arrives in my Inbox and I double-click it to open the message, I'm only wanting to deal with that particular new message.  But if I click delete to get rid of it, Thunderbird then opens the message just above it in my Inbox.  I didn't want to deal with that message at all, and this simple procedure now requires additional clicks just to close that message and possibly to mark it as unread if I wanted it left that way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 505604
You need to log in before you can comment on or make changes to this bug.