status messages added to the add-ons manager can force the content to be too wide for the window ("Add-on compatibility checking is disabled")

VERIFIED FIXED in mozilla2.0b7

Status

()

defect
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: wgianopoulos, Assigned: mossop)

Tracking

({regression})

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite -
in-litmus ?

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [good first bug])

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
The new messages added by bug 566194 can easily force the content to be too large for the window, and there is no horizontal scrollbar.

A horizontal scrollbar needs to be displayed if it is required.
(Reporter)

Updated

9 years ago
blocking2.0: --- → ?
(Reporter)

Updated

9 years ago
Blocks: 566194
No longer blocks: 593754
(Reporter)

Comment 1

9 years ago
(Reporter)

Comment 2

9 years ago
I tried this on my Windows/XP laptop which only has 1024x768 resolution, and the situation is worse there.

Even without the sidebar displayed, and the window maximized, the right hand side of the window, including the vertical scrollbar is off screen, so not only do you have no horizontal scrollbar, but the vertical scrollbar is positioned off the screen.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 594130
(Assignee)

Updated

9 years ago
blocking2.0: ? → final+
Whiteboard: [good first bug]
Duplicate of this bug: 594316
Even 1280px of horizontal space are not enough to display the "Addon compatibility..." message.

FWIW I don't think a horizontal scrollbar is the way to go here as it will be very ugly. Maybe letting the text wrap could be an option here?
(Assignee)

Comment 7

9 years ago
Yes, the text should wrap.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 593856
Using the following try server build 

http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/dwillcoxon@mozilla.com-62621772d7e4/

the scrollbars issue disappears
(Assignee)

Updated

9 years ago
Duplicate of this bug: 594866
Adding the text of the status-message ("Add-on compatibility checking is disabled") to bug summary, to make it easier for people to find this bug (and reduce the number of duplicates).
Summary: status messages added to the add-ons manager can force the content to be too wide for the window → status messages added to the add-ons manager can force the content to be too wide for the window ("Add-on compatibility checking is disabled")
(Assignee)

Updated

9 years ago
Duplicate of this bug: 595144
Duplicate of this bug: 595217
(Assignee)

Updated

9 years ago
Assignee: nobody → dtownsend
(Assignee)

Comment 15

9 years ago
Posted patch patch rev 1Splinter Review
This seems to do the trick
Attachment #474301 - Flags: review?(bmcbride)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 16

9 years ago
(In reply to comment #15)
> Created attachment 474301 [details] [diff] [review]
> patch rev 1
> 
> This seems to do the trick

Works fine for me as well.
Attachment #474301 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 17

9 years ago
landed: http://hg.mozilla.org/mozilla-central/rev/a0cb638ed3a5

Can't really automatically test it, probably worth a quick automated test
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite-
Flags: in-litmus?
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
(Assignee)

Comment 18

9 years ago
(In reply to comment #17)
> landed: http://hg.mozilla.org/mozilla-central/rev/a0cb638ed3a5
> 
> Can't really automatically test it, probably worth a quick automated test

Probably worth a quick manual test I mean.
(In reply to comment #17)
> landed: http://hg.mozilla.org/mozilla-central/rev/a0cb638ed3a5
> 
> Can't really automatically test it, probably worth a quick automated test

Will this land on the nightlies soon?
(Assignee)

Comment 20

9 years ago
(In reply to comment #19)
> (In reply to comment #17)
> > landed: http://hg.mozilla.org/mozilla-central/rev/a0cb638ed3a5
> > 
> > Can't really automatically test it, probably worth a quick automated test
> 
> Will this land on the nightlies soon?

It just landed so it will be in the next nightly
(In reply to comment #20)

It just landed so it will be in the next nightly

Cool, thanks!
Verified fixed with builds on all platforms like Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100922 Firefox/4.0b7pre
Status: RESOLVED → VERIFIED
This bug is showing again in trunk since yesterday at least. (No horizontal nor vertical scrollbars in the add-ons manager when Add-on compatibility checking is disabled)
WFM, using today's trunk nightly. (with the "addon compatibility checking is disabled" message present)
(Reporter)

Comment 25

9 years ago
(In reply to comment #23)
> This bug is showing again in trunk since yesterday at least. (No horizontal nor
> vertical scrollbars in the add-ons manager when Add-on compatibility checking
> is disabled)

(In reply to comment #23)
> This bug is showing again in trunk since yesterday at least. (No horizontal nor
> vertical scrollbars in the add-ons manager when Add-on compatibility checking
> is disabled)

This is actually a separate issue which was reported in bug 603120 and should be fixed in bug 595842.
You need to log in before you can comment on or make changes to this bug.