Thunderbird trunk startup with black window

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: williejreid, Unassigned)

Tracking

({platform-parity})

Trunk
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b6pre) Gecko/20100906 Thunderbird/3.2a1pre

todays nightly installs but opens with black unresponsive screen, no panes are visible. Title bar has some information e.g current folder selected. Starting in safe mode result in similar blackness. 
Trying to access profile manager = black dialogs with some response to mouse clicks but I'm clicking blindly. 
Incoming or unread mail allows revealing of data, bars and buttons. 
Tools.. Add-ons presents no extension or other info.

Reproducible: Always
Confirmed here but setting layers.accelerate-all = false can used as workaround.

It seems that this issue affect only Windows OS.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: pp
Summary: todays nightly opens as black window. → TB start with black window.
...the strange thing is that this issue don't occur in safe-mode (maybe in safe-mode layers.accelerate-all = false ?)
I see the same problem on Windows XP Service Pack 3.
Could be linked to bug 581212 (see Bug 593858).
Do you use an Intel GMA video card ?
Might be right. I have an Intel GMA 4500M
I'm seeing this as well with a Intel GMA 965.
Component: General → Graphics
Product: Thunderbird → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Summary: TB start with black window. → Thunderbird trunk startup with black window
(In reply to comment #4)
> Could be linked to bug 581212 (see Bug 593858).
> Do you use an Intel GMA video card ?

Me too Intel video card (Mobile Intel (r)4 series express)
Blocks: d3d9-layers
Bas what is this a dup of ?
This affects Firefox (trunk), too; see bug 594055.

You can workaround this (at least in Firefox) using "-safe-mode", since "-P" triggers the black window always (despite of the layers.accelerate-all setting).
I'm seeing something similar, but it only shows up when I minimize the window and later attempt to restore it (and even then, it's not every time.) At startup, everything is fine. Quitting and restarting TB fixes it for a while.
Willie, do you still see this with current trunk builds?
This does not seem to be happening anymore. It was likely fixed by something which landed over the past year. Please reopen if you're still seeing this.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
note HWA is going to be disabled in TBird version 9
ref Bug 689742] Set layers.acceleration.disabled to true
Currently using Mozilla/5.0 (Windows NT 6.0; rv:11.0a1) Gecko/20111202 Thunderbird/11.0a1 ID:20111202030052.
And no, this is not happening now.
You need to log in before you can comment on or make changes to this bug.