"Swing state polls" does not show anything

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Keith Hankin, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Chart on specified URL titled "Swing state polls" does not show anything, even
when names of states clicked.
I can't find the chart you refer to with either Mozilla or Netscape 4.x....
(Reporter)

Comment 2

17 years ago
Apparently, the chart has moved to another 
page: http://www.msnbc.com/news/337140.asp
Curiously, the problem no longer appears there.
Hmm..  I tried the chart, and I _do_ see the problem with linux trunk build
2000110521.

The problem I observe is that they have links with href="javascript:function()"
and they expect the function to get executed on the current document.  Mozilla
does not do so:

Error loading URL javascript:Swapcopy('keyStates',4);: 805303f5

While the proper way to do what they are doing is of course to have an onclick
handler for the link, should the href approach work as well?

Comment 4

17 years ago
over to DOM for evaluation.
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale
(Assignee)

Comment 5

17 years ago
Mozilla does support href="javascript:function();" type links (the error message
is bogus, you always get that with javascript: URL's event if they work as
expected) so that's not the problem, I'm unable to find the chart on any of the
URL's mentioned here, I can't reproduce this problem.

Will mark INVALID unless someone points me to the chart...
The chart seems to be gone...  msnbc is not very good at not changing its
content around. :(
(Assignee)

Comment 7

17 years ago
Ok, not much we can do then unless someone happens to have a local copy that
could be attached to this bug. Marking INVALD since there's no way to reproduce
this now, please reopen if a testcase appears...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 8

17 years ago
VERIFIED invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.