"Assertion failure: !inDictionaryMode(),"

RESOLVED DUPLICATE of bug 595365

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 595365
7 years ago
7 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

7 years ago
'aa'.replace(/a/g,
function() {
    delete y;
    y = [];
})

asserts js debug shell on TM changeset 7ef38f42e7c8 without -m nor -j at Assertion failure: !inDictionaryMode(),
(Reporter)

Comment 1

7 years ago
Probably related to bug 558451.

Regression window:

http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=be9979b4c10b&tochange=f3e58c264932
Blocks: 558451

Updated

7 years ago
blocking2.0: ? → betaN+
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595365
You need to log in before you can comment on or make changes to this bug.