Closed Bug 593950 Opened 11 years ago Closed 11 years ago

When drawing in the title bar and using Glass, the title bar should be smaller

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: dao, Assigned: dao)

References

Details

Attachments

(2 files)

maybe if/when titlebar will be small, bug 576952 will happen again.
(now fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=575870#c99)

so title bar should not be small.
blocking2.0: ? → betaN+
This causes a rather ugly "jump" when entering full screen mode, because the window draws fullscreen once with the negative margin, and then again without, before starting the animation. I'm not sure why the transition is so noticeable - I wonder whether it can be worked around with a forced reflow somewhere...
(In reply to comment #2)
> This causes a rather ugly "jump" when entering full screen mode, because the
> window draws fullscreen once with the negative margin, and then again without,
> before starting the animation. I'm not sure why the transition is so noticeable
> - I wonder whether it can be worked around with a forced reflow somewhere...


I'm seeing the same thing in 591930. I looked into it, what happens is that on the transition to fullscreen, the sizemode attribute isn't updated immediatelly. The code that sets it is the code that saves the persistent attributes, and it fires off of a timer.
( http://mxr.mozilla.org/mozilla-central/source/xpfe/appshell/src/nsWebShellWindow.cpp?mark=357,374-377#357 )

Note that the inFullscreen attribute works as expected (if you use it on the CSS you won't see the jump), so a front-end workaround would be to set sizemode="fullscreen" on the same code that sets inFullscreen="true"


For transitions between normal/maximized windows the problem doesn't happen because an activate event forces the attribute to be set immediatelly
( http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/nsWindow.cpp?mark=1646-1649#1646 goes to
http://mxr.mozilla.org/mozilla-central/source/xpfe/appshell/src/nsWebShellWindow.cpp?mark=437,450-452#437 )

Another fix is to call the activate event for the fullscreen transition too.
(In reply to comment #3)
> (In reply to comment #2)
> > This causes a rather ugly "jump" when entering full screen mode, because the
> > window draws fullscreen once with the negative margin, and then again without,
> > before starting the animation. I'm not sure why the transition is so noticeable
> > - I wonder whether it can be worked around with a forced reflow somewhere...
> 
> 
> I'm seeing the same thing in 591930. I looked into it, what happens is that on
> the transition to fullscreen, the sizemode attribute isn't updated
> immediatelly. The code that sets it is the code that saves the persistent
> attributes, and it fires off of a timer.
> (
> http://mxr.mozilla.org/mozilla-central/source/xpfe/appshell/src/nsWebShellWindow.cpp?mark=357,374-377#357
> )
> 
> Note that the inFullscreen attribute works as expected (if you use it on the
> CSS you won't see the jump), so a front-end workaround would be to set
> sizemode="fullscreen" on the same code that sets inFullscreen="true"

We really don't want that, I think, but we could add :not([inFullscreen=true]) to the selector. That might affect the transition out of fs mode badly, though.
Duplicate of this bug: 582020
(In reply to comment #4)
> we could add :not([inFullscreen=true]) to the selector

That works fine (I don't see any negative effects). It also helps for all the other #main-window[sizemode="normal"] styles too. But it doesn't help the case where we're transitioning from maximized (not fullscreen) to normal (or vice-versa), though... We should handle that in a separate bug I guess.
Comment on attachment 472599 [details] [diff] [review]
patch

We have jitteriness on transition with or without this due to the existing [sizemode="normal"] styles, so as-is it doesn't really make things much worse.
Attachment #472599 - Flags: review?(gavin.sharp) → review+
Um, comments 6-7 are me (I was using johnath's PC).
http://hg.mozilla.org/mozilla-central/rev/80a39b6421b5
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
bug 576952 happen again after this fix.
if intended, why ?
too BAD.
Depends on: 607251
(In reply to comment #10)
> bug 576952 happen again after this fix.
> if intended, why ?
> too BAD.

no answer ??
No longer depends on: 607251
Depends on: 576952
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7
Border Padding in Window Appearance settings directly affects how big the gap between the Firefox button and tabs is.
This fix I think has made it so that when Border Padding is set to zero pixels, the tab starts right at the bottom of the Firefox button, which looks quite cramped.
You need to log in before you can comment on or make changes to this bug.