If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

app tabs are shorter than normal tabs with a gap below the bottom border

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

({polish})

Trunk
x86
Linux
polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 472621 [details]
screenshot with white lines below app tabs

Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre

Apps tabs have a white bottom that looks bad next to normal tabs, see screenshot.

Updated

7 years ago
Depends on: 593690

Updated

7 years ago
Duplicate of this bug: 595477

Comment 2

7 years ago
Just a note, that although bug #593690 reduces the occurence of this bug, it does still happen - for example, if you drag the bookmarks bar next to the tab bar, that increases the height of tabs and shows up this bug again.

Is there a technical reason why the app tabs are drawn differently to the normal tabs, such that this breakage occurs?

Comment 3

7 years ago
(In reply to comment #2)
> Just a note, that although bug #593690 reduces the occurence of this bug, it
> does still happen - for example, if you drag the bookmarks bar next to the tab
> bar, that increases the height of tabs and shows up this bug again.
> 
> Is there a technical reason why the app tabs are drawn differently to the
> normal tabs, such that this breakage occurs?

I can confirm this behaviour with Firefox4 using Windows7. (bookmark item list is in tab toolbar)
I think this is a dupe of bug 597353...

Comment 5

7 years ago
I can confirm that this is still happening with the latest trunk build when bookmark item list is in tab toolbar. Removing list from the tab toolbar will sometimes correct the problem.

Comment 6

7 years ago
it is not "white space" but a transparent gab below the bottom border
Summary: app tabs are shorter than normal tabs and have white space at bottom → app tabs are shorter than normal tabs with a gab below the bottom border
Summary: app tabs are shorter than normal tabs with a gab below the bottom border → app tabs are shorter than normal tabs with a gap below the bottom border
I am now seeing this in Linux nightly builds, with the following steps to reproduce:

1. Hide the menu bar (adds the Minefield button to the tab bar).
2. Open enough tabs to force scroll arrows to appear in the tab bar.

The gap appears when the scroll arrows do, but does not go away when they disappear (after closing some tabs).
blocking2.0: --- → ?
Keywords: polish
Blocks: 585164
I see this with the menu bar hidden, which is a non-default option.

While ugly, we won't hold the release for this non-default scenario. Would love to see it fixed though, because since since reading this bug I keep staring at the stupid gap.
blocking2.0: ? → -
(In reply to comment #7)
> I am now seeing this in Linux nightly builds, with the following steps to
> reproduce:
> 
> 1. Hide the menu bar (adds the Minefield button to the tab bar).
> 2. Open enough tabs to force scroll arrows to appear in the tab bar.
> 
> The gap appears when the scroll arrows do, but does not go away when they
> disappear (after closing some tabs).

This is bug 614925.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.