Show images with Right click > View image, event with permissions.default.image set to 2

RESOLVED DUPLICATE of bug 187452

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 187452
8 years ago
8 years ago

People

(Reporter: Pierre Rudloff, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.10pre) Gecko/20100903 Camino/2.1a1pre (like Firefox/3.6.10pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.10pre) Gecko/20100903 Camino/2.1a1pre (like Firefox/3.6.10pre)

I have a slow connection so I disable the images, but sometime I want to see an image by clicking View image in the contextual menu.
It works with permissions.default.image set to 3 but not to 2.

Reproducible: Always
I suspect that's because when you use View Image, the image is loaded as a first-party image, i.e. the image host and the "site" host are the same, and 3 only blocks third-party loads.  2 blocks all images, period.

The tail end of bug 187452 talks about possible ways to get around this; I'm not sure we'd necessarily provide UI for blocking images any more, but getting the problems with 2 fixed are a prerequisite for doing UI, so this is a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187452
You need to log in before you can comment on or make changes to this bug.