If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Choosing "View frame source" on a not yet loaded frameset sometimes causes Moz to show the XML source of its own interface, then crash

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
minor
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: noog, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2000101014

I was viewing a page "hosted" by www.cjb.net (a free, frame-based redirection 
service). Since it was taking ages to load, I decided to stop the loading, and 
tried to view the source for the page to get an idea of how much of it had been 
loaded. "View source" displayed a disappointing "<html><body></body></html>", 
so I tried "View frame source". The source viewer comes up, and inside it a lot 
of HTML-like "garbage". I took some time examinating it, well, it was the XML 
source for the interface itself. I closed the source viewer, and Moz crashed. I 
guess the frameset element hadn't been even created when I right-clicked the 
view frame, so I actually right-clicked the underlying interface layer

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1.Open a framed document
2.Prematurely abort loading
3.Choose "view frame source" from the context menu

Actual Results:  The browser crashed (invalid page fault in an unknown module)

Expected Results:  Moz should have pop up a blank source viewer

Fault log:

Data 11/07/2000 Ora  20:31
MOZILLA ha provocato un errore di pagina non valida nel
modulo <sconosciuto> in 0084:010eaf08.
Registri:
EAX=017aad54 CS=0167 EIP=010eaf08 EFLGS=00010246
EBX=00000000 SS=016f ESP=0068f170 EBP=0068f184
ECX=010eaeb8 DS=016f ESI=0180e0a0 FS=117f
EDX=0068f180 ES=016f EDI=0180e0a0 GS=0000
Byte all'indirizzo CS:EIP:
00 af 0e 01 08 af 0e 01 08 af 0e 01 10 af 0e 01 
Immagine dello stack:
604d14c2 017aad54 0068f180 604d95e0 00000000 0068f1bc 604d157c 00000000 
0180e0a0 006d1130 60d17638 009a3ea0 00000000 60d17638 009a3ea0 00000000

Comment 1

17 years ago
haven't seen this problem. over to XPApps
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
hrm, i couldn't repro this --have you tried a more recent build? i've been using
2000.11.08.01 comm opt branch bits on winNT...
Keywords: crash

Comment 3

17 years ago
Is anyone still seeing this problem?

Comment 4

17 years ago
Several attempts to reproduce this on 2000121508 Win98. Cannot.
Resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.