Harland/UltraData Internet Banking virtual keyboard step disabled when login is initiated via home page iframe

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: ccoffman, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)

We are a credit union using Harland/UltraData's internet banking platform (Ultra Access).  They supplied code (.vm format) for a login page which works in all browsers, and a login "box" (small iframe embedded in our home page), which works in everything but Firefox.

When a user enters their member number and a security code on our home page (coastccu.org), they are asked a security question, then taken to a virtual keyboard.  These steps are fine in all browsers, but the Firefox problem comes in when the user tries to "type" on the virtual keyboard.  When holding their mouse over the keys, they do highlight, but do not register when clicked.  This prevents Firefox users from using the login box on the home page.  UltraData/Harland has not been able to help us.

Reproducible: Always

Steps to Reproduce:
Please call or email me for the login information - we have a sample account you can use but need to keep it as confidential as possible.  There's a member number, security image, and a set of security questions (hard to tell which one you will get) before the PIN step.
Actual Results:  
PIN does not register in the box above the virtual keyboard.  If submitted, the login process fails.

Expected Results:  
PIN should register (each digit as a bullet or asterisk) in the box above the virtual keyboard, and when submitted, user will be logged in to online banking.

Every member we have with Firefox has this same problem.  Process works in all versions we've tried of Internet Explorer, Google Chrome, and Safari.

Comment 1

8 years ago
Does the issue still occur with the latest version?

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

Are there any errors in the error console?
Version: unspecified → 3.6 Branch

Comment 2

8 years ago
Reporter -> Are you still experiencing this issue? Have you tried safe mode or a new profile? Please address the other questions in comment 1

Comment 3

7 years ago
Closing bug as Incomplete - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.