Middle-mouse scroll (autoscroll) cursor isn't painted correctly when deactivated

RESOLVED DUPLICATE of bug 588403

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 588403
8 years ago
8 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When I stop autoscroll by clicking the middle mouse button, the area under the autoscroll cursor is not repainted properly.

STR:
* open a page with lots of text
* middle-click the mouse to autoscroll
* move the mouse down to scroll down a bit
* middle-click the mouse again

Actual results:
* When the mouse cursor changes from autoscroll back to a regular cursor, the area under the cursor is not repainted properly. In fact, the area under the cursor is not repainted during scrolling either, which is especially distracting because it's a transparent cursor.

Expected result:
* The area under the cursor should be up to date during and after scrolling


        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre

  Graphics

        Adapter Description
        NVIDIA Quadro FX 1700

        Vendor ID
        10de

        Device ID
        040f

        Adapter RAM
        512

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.11.9621

        Driver Date
        1-11-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Layers Enabled
      2/2 Direct3D 9

I'm pretty sure this is a recent regression.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588403
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.