Investigate why we have so many nameless collections in Prod

VERIFIED FIXED in 5.12

Status

addons.mozilla.org Graveyard
Collections
P2
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Details

(Whiteboard: [z], URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1.Load https://addons.mozilla.org/en-US/firefox/collections/?sort=created
2.Notice all the name-less add-ons

We should not be having nameless add-ons as collection_name is a required field. Please look into why we have so many nameless one out there.
Assignee: nobody → jbalogh
Priority: -- → P2
(Assignee)

Comment 1

8 years ago
I bet this is because of string locales not matching the default locale of the collection.  We probably should not bother looking at the locale for collection strings since you can't add translations.
(Assignee)

Comment 2

8 years ago
http://github.com/jbalogh/zamboni/commit/4bbfef7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
verified at-
https://preview.addons.mozilla.org/en-US/firefox/collections/nydile123/ 
 
There are collections with names in Russian,Hebrew,Arabic,Japanese and Chinese. None of the newly-created collections are nameless.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.