Add Windows 7 style hover effect to App Button

RESOLVED WONTFIX

Status

()

Firefox
Theme
--
enhancement
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: imradyurrad, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre

In Win7, hovering over a taskbar item creates this color shift effect that follows the cursor around. 

It'd be nice if the App Button behaved the same.

Reproducible: Always

Steps to Reproduce:

3.
(Reporter)

Updated

8 years ago
Whiteboard: [polish]
(Reporter)

Updated

8 years ago
Depends on: 594037
(Reporter)

Updated

8 years ago
Summary: Add Windows 7 style animation effects to App Button → Add Windows 7 style hover effects to App Button
(Reporter)

Updated

8 years ago
Summary: Add Windows 7 style hover effects to App Button → Add Windows 7 style hover effect to App Button
Component: Shell Integration → Theme
QA Contact: shell.integration → theme

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

8 years ago
This breaks platform UI consistency I think. The color shift effect is only for taskbar not for window frames.

I'd say the Fx button should match the behavior exhibited by the minimize, maximized, close buttons. There should be a smooth transition or fade between normal state and highlighted state when mousing over Firefox button.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)

The app button behaves more like the taskbar though. Clicking on it brings up a list, much like leftclick+drag up/right clicking the taskbar icons.

Comment 3

8 years ago
No app button behaves more like a menu, and that's what it should be considered as. Taskbar items represent individual programs that you can choose to call to the forefront or send to the background. Menus show tasks that a certain application can do. Firefox button clearly falls into the later category.

Take a look at MS applications that draw app buttons in titlebar and you'll see no color shift effect used. Some MS applications do use fade effects however, like MS Office 2007.

Here's my reasoning for adopting a more conservative fade effect:
1.) Since the new Fx button design clearly takes painstaking effort to emulate the minimize/maximize/close buttons (just look at how it turns transparent when Fx window isn't active, exactly like minimize/maximize/close buttons), we should go all the way and adopt the fade/glow effect that they use as well.

2.) A color shift effect might look fitting in a Windows 7 environment, but in any other windows version it will look completely out of place, especially in Windows XP

3.) The color shift effect is a bit distracting IMHO and could get annoying over time.
(Reporter)

Updated

7 years ago
Depends on: 536540

Comment 4

4 years ago
Obsoleted by Australis.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.