Last Comment Bug 594244 - Some arrow extenders are borked in Seamonkey nightlies with STIX v1
: Some arrow extenders are borked in Seamonkey nightlies with STIX v1
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: mozilla2.0b8
Assigned To: Frédéric Wang (:fredw)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-07 20:07 PDT by distler
Modified: 2010-11-10 15:17 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (2.31 KB, application/xhtml+xml)
2010-09-07 20:07 PDT, distler
no flags Details
Rendering in Seamonkey nightly (33.22 KB, image/png)
2010-09-07 20:08 PDT, distler
no flags Details
Rendering in Firefox nightly (30.34 KB, image/png)
2010-09-07 20:09 PDT, distler
no flags Details
Patch V1 (3.09 KB, patch)
2010-11-06 13:40 PDT, Frédéric Wang (:fredw)
karlt: review+
benjamin: approval2.0+
Details | Diff | Splinter Review

Description distler 2010-09-07 20:07:02 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100901 SeaMonkey/2.1b1pre
Build Identifier: 

The extenders for hookleftarrow, hookrightarrow and mapsto are borked in Seamonkey (see the screenshot). Firefox is better, thought it stretches the characters hookleftarrow, hookrightarrow, rather than extending them (see the screenshot).

Reproducible: Always
Comment 1 distler 2010-09-07 20:07:53 PDT
Created attachment 472910 [details]
Testcase
Comment 2 distler 2010-09-07 20:08:43 PDT
Created attachment 472911 [details]
Rendering in Seamonkey nightly
Comment 3 distler 2010-09-07 20:09:18 PDT
Created attachment 472912 [details]
Rendering in Firefox nightly
Comment 4 Karl Tomlinson (:karlt) 2010-09-07 20:27:01 PDT
E10B "stix-extender for horizontal solid (normal) arrow", which was in STIX Beta is not in v1.0.0.  I wonder what the intended replacement was.
U+23AF HORIZONTAL LINE EXTENSION maybe.
Comment 5 Frédéric Wang (:fredw) 2010-11-06 13:40:14 PDT
Created attachment 488691 [details] [diff] [review]
Patch V1
Comment 6 Karl Tomlinson (:karlt) 2010-11-07 20:39:09 PST
Comment on attachment 488691 [details] [diff] [review]
Patch V1

I would be good to get this very confined change into Gecko 2.0 as more and more people will be moving to STIX v1.0.0 fonts.
Comment 7 Karl Tomlinson (:karlt) 2010-11-10 15:17:14 PST
http://hg.mozilla.org/mozilla-central/rev/f551a45cefbd

Note You need to log in before you can comment on or make changes to this bug.